Updating AFNI on Ubuntu 12.04


I was attempting to do an AFNI update in order to gain access to some newer options (specifically the ACF method of 3dClustsim). The @update.afni.binaries command could not be recognized on my Ubuntu 12.04 system. So I was attempting a manual update by downloading the linux.ubuntu_16_64.tgz package. This however, was stopped part of the way through as it could not recognize the directory from which my matlab was being run when I was asked to specify. Now, when I open AFNI (which opens fine) even the most basic commands will no longer run, like 3dinfo. Instead I get the following

/lib/x86_64-linux-gnu/lib.so.6: version ‘GLIBC_2.23’ not found(required by 3dinfo).

I suspect that the update getting aborted halfway through meant it was replacing certain drives/files and did not finish. So to try to remedy this mess I thought perhaps I should just re-download AFNI altogether, and hopefully that would solve bother problems, as it would give me the most updated version with the needed new options. However, none of the sudo commands for the 15.10 and earlier AFNI installations appear to be working in my terminal. whenever I enter sudo apt, I get 'command not found", sudo -apt, simply gives me information about the inputs sudo expects, none of which are in the format of the AFNI download instructions. I also tried sudo -yum, but that does not seem to work either. If anyone has encountered similar issues to this, I would greatly appreciate it. It seems I’ve managed to take what was a simple problem and make it far more complicated than necessary. Thanks in advance!


Hi Sam,

The ubuntu_16 package will not be appropriate for
an Ubuntu 12-15 system.

In any case, it sounds like your PATH is messed up,
hopefully for just the current terminal window.
Open a new window, and see whether commands like ls
and @update.afni.binaries work:

ls -l
@update.afni.binaries -help

If so, it is probably appropriate for you to use
the linux_openmp_64 package, so get that with:

@update.afni.binaries -package linux_openmp_64

Avoid running any sudo commands when your PATH
may be messed up.

  • rick

Hi Rick,

Thanks for the quick response! In a new terminal, yes my commands like ls and @update.afni.binaries are recognized. However, if I attempt to run a specific package, or even defaults with the @update.afni.binaries I get an error which says I do not have write permissions in the install directory (install dir = /usr/bin), my IT dept has told me they do not have admin control over this server since it is linux based. This is why I was attempting to run it with sudo, but when I do so, as shown below, it asks for my password, and after I give it, it tells me the command is not found
sudo -@update.afni.binaries -package linux_openmp_64

Thanks again!

It sounds like you may be using the NeuroDebian AFNI package,
in which case using @update.afni.binaries is not appropriate.

Does “afni -ver” show anything? If so, what?
What is the output of: afni_system_check.py -check_all

  • rick

It seems you’re right. afni-ver returns the following

Precompiled binary Debian=x86_64-1-gnu: June 12 2017 (Version-16.2.07~dfsg.1-5~nd12.04+1

I’m not sure to what the June 12 2017 refers. When my afni commands were still working, I verified that the 3dclustsim being run by my current installed AFNI was from 2014(hence my need for an updated version for the new 2015 add ons). The output for afni_system_check.py -check_al is below. Thank you.

=========== afni_system_check.py version 0.5, August 26, 2013 ============

-------------------------------- general ---------------------------------
architecture: 64bit ELF
system: Linux
release: 3.8.0-44-generic
version: #66~precise1-Ubuntu SMP Tue Jul 15 04:01:04 UTC 2014
distribution: debian wheezy/sid
number of CPUs: 2
apparent login shell: bash

--------------------- AFNI and related program tests ---------------------
which afni : /usr/bin/afni
Traceback (most recent call last):
File “/home/sarah/abin/afni_system_check.py”, line 267, in
File “/home/sarah/abin/afni_system_check.py”, line 261, in main
rv = me.execute()
File “/home/sarah/abin/afni_system_check.py”, line 247, in execute
if self.sys_check: self.show_system_info()
File “/home/sarah/abin/afni_system_check.py”, line 241, in show_system_info
File “/home/sarah/abin/lib_system_check.py”, line 100, in show_general_afni_info
s, v = self.get_prog_version(prog)
File “/home/sarah/abin/lib_system_check.py”, line 142, in get_prog_version
off1 = so[1].find(‘[[’)
IndexError: list index out of range

Hi Rick,

I want to check if there is a different package I should try updating, or re-installing, based on the output information I sent in my last response. It seems Debian weezy/sid was what was installed previously. As I said, AFNI will still open when called in the terminal, but 1. None of my commands will run in the terminal and 2. Even restoring back to what I had originally, is an outdated package, and I need to update to utilize newer options. Thanks again for any help!


Hi Sam,

If you want to get away from the Neurodebian AFNI package,
the first thing to do is properly uninstall it, probably with a
command like:

sudo apt-get remove afni

To be sure, the command “which afni” should not return

After that, try Step 3 from the Ubuntu install instructions.

  • rick

Thanks for the response, Rick. If I try to run the command to remove AFNI, I’m given the following Error E: Could not get lock /var/lib/dpkg/lock -open (11:Resource temprarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

When I navigate to that file directory, the lock document cannot be opened, it says I do not have the permissions. This is after trying sudo chmod +rxw on the directory/file. Our admin said that the linux system is not under their control, and I would think that with sudo commands I am operating as root. Am I confusing something here about how to gain admin privileges? Thank you for your help, and let me know if you are unable to help as this drifts from being an AFNI specific issue to a more general linux issue. I appreciate it!

Updated: Per review of previous messages on here, I’m going to just delete the abin directory, it only contains AFNI documents. From there I will attempt the step 3 installation instructions you suggested and hopefully that works smoothly. Thank you!


Hi Sam,

Maybe you are running other apt commands. If
“sudo apt-get remove afni” keeps failing, you
might want to rename /usr/bin/afni, e.g.

sudo mv /usr/bin/afni /usr/bin/afni-debian

Of course, doing that may make it more difficult
to remove the Debian AFNI package. But you can
rename it back to just afni at any time.

Note that to run the openmp_64 binaries, it may be
necessary to install a couple of the libraries mentioned
earlier in those instructions.

  • rick