updating afni binaries


I have been trying to update afni on my local machine (iMac, OS 10.13.6) using @update.afni.binaries -d with no success.
I first called @update.afni.binaries -d which resulted in ‘no update needed’. I then tried the following

curl -O https://afni.nimh.nih.gov/pub/dist/bin/linux_xorg7/@update.afni.binaries
chmod 755 @update.afni.binaries
@update.afni.binaries -d

I got the same message. afni -ver still shows the following:
Precompiled binary macosx_10.7_local: Aug 28 2018 (Version AFNI_18.2.15)


Hi, Golbarg-

The 10.7_local version is no longer updated. You can (+should) update by switching over to the 10.12_local binaries:

@update.afni.binaries -defaults -package macos_10.12_local

After that, you should be uptodate and good to go.


Hi Paul,

Thank you, it worked on my mac.

We have had a similar issue with updating afni on a Linux server (Centos 7, 64 bit). @update.afni.binaries doesn’t update, and afni -ver returns:
Precompiled binary linux_centos_7_64: May 30 2018 (Version AFNI_18.1.23)

Please let me know which package should be called with @update.afni.binaries for Linux.

Hi Golbarg,

That is peculiar, since the centos_7 binaries have been updated
many times since then. I wonder if there is an ownership problem
on your end.

Would you please post or mail me (click on my name) the output
from an update attempt?

@update.afni.binaries -d
  • rick

Hi Golbarg,

Thanks for the @update text.

It looks like your sysadmin has a different version of
AFNI in their path, linux_openmp_64, and there is
nothing to update there.

They can either set the PATH to point to the same
version you are running (which afni), or then can
specify the package and install dir on the command
line, e.g.,

@update.afni.binaries -package linux_centos_7_64 -bindir /for/example/usr/local/abin
  • rick

Thank you. We were able to get the latest version.