Unable to extract macos_10.12_local.tgz

Hello everyone,

I am trying to install afni on a colleague’s mac computer however the installation keeps failing giving a failure to extract the install package (see attached image). I have tried the app install as well and that failed too. Any help would be appreciated.

Screen Shot 2018-12-12 at 2.01.26 PM.png

That is peculiar.

To be sure, what OS version are you running?
And exactly what command did you use?

What is the result of running it as this?

tcsh @update.afni.binaries -d
  • rick

Hi Rick,

Thanks for the quick response. The system is 10.13.6 High Sierra, the system is a Macbook Air.

The command you gave crashed with the same error.

I have tried the following commands:

tcsh @updates.afni.binaries -defaults -package macos_10.12_local
tcsh @updates.afni.binaries -defaults -local_package macos_10.12_local (with package downloaded on the computer)

Did you show the entire output before? The reason I ask is that
it does not seem to be quite the current output, yet getting the
current version should be the first thing it does.

What is the output of: ls -l ~/abin/.tmp.install ?

If there is a .tgz file there, does it seem incomplete? I am not
sure why else the tar command would fail. What is the output
from: “which tar” and “tar --version”?

  • rick

I have attached the full output of what I ran before and also the output of ls -l ~/abin/.tmp.install.

The .tgz file looks like it is complete and nothing wrong with it.

For which tar the output is /usr/bin/tar

For tar --version the output is bsdrar 2.8.3 - libarchive 2.8.3

I am not quite sure what to make of this. I have the same version
of tar here, and the options are fine. And your .tgz package has
the same size of what is on the web site. What happens when you
run it directly (since maybe tcsh points you to a different version)?

cd abin/.tmp.install
tar xfz macos_10.12_local.tgz

  • rick

Hi Rick,

I have been banging my head at this problem today and I was finally able to install AFNI. I became a bit desperate and thought maybe the permissions on the tgz file were incorrect so I changed the permissions on the file (good old chmod 777) and afni was installed. I’m not sure why the permissions on the tgz package had to be changed, it may be some sort security setting my colleague has set up on her computer. I honestly don’t know enough about these things and should learn more! Thank you for your help and quick responses


Strange. That suggests you did not have read access. But from what I can tell, you were working via the user’s account (not doing any sudo things), is that right?

Anyway, I am glad you got it working. Maybe I should add a “chmod a+r” command, though I have never heard of this happening before.

  • rick

Yes I was working with the user account. I have never had any issues installing afni on a system till this one, it was a very strange problem.