Trying to install AFNI via VirtualBox on Ubuntu 18.04

I’m trying to use AFNI via VirtualBox but when I did the AFNI check to ensure it was properly installed, I got the error message that afex, phia, and brms were not installed. I tried downloading them individually but I then received a message that those libraries have been installed. However, the message then states that - installation of packages: curl, PKI, RCurl, rio, rsconnect, Car, Shinystan, afex, phia, and brms had non-zero exit status. Any advice would be great!!


We haven’t checked this on a 18.04 Ubuntu machine internally, but this thread describes a dependency installation for that system that seemed to resolve the issue:,158650,158650

Also, can I ask why are you using a virtual box? I would imagine that performance would not be as great as with a straightup AFNI installation, which is possible on either Mac, Windows or various flavors as described here:


Many thanks PT! I’ll look into both of those,

I’m still having trouble with numerous missing packages in R. I downloaded an older version of Ubuntu (16.04) but I received the same error message.

I tried the various solutions stated on the other threads (i.e. sudo apt-get install openssl openssl-dev; libcurl4-openssl-dev; sudo apt-get install libssl-dev before doing a reinstall of R). Unfortunately, I still receive the same message. I’ve tried downloading them individually but to no avail. I’m at a loss. Any help would be great!!

Issue resolved! I did the following

sudo apt-get install libssl-dev
sudo apt-get install libcairo2-dev
sudo apt-get install libxml2-dev
sudo apt-get install default-jdk
sudo R CMD javareconf
sudo apt-get install libcurl4-openssl-dev
Then I did individual installs but brms was still not working, and I fixed that with this

sudo add-apt-repository -y “ppa:marutter/rrutter”
sudo add-apt-repository -y “ppa:marutter/c2d4u”
sudo apt-get update
sudo apt-get install r-cran-rstan
sudo apt-get install r-cran-shinystan
sudo apt-get install r-cran-brms

Then I did I check and everything came back ok. :slight_smile:

Intriguing… OK, thanks for solving that.