SUMA thresholding failure

AFNI team,
I have just installed AFNI and SUMA on a Mac mini (Mojave 10.14.6). I did my best to pay attention to the install, ran afni_system_check_all and had no errors but when I run SUMA and try to threshold an image I am unable to do so. I change the threshold value but nothing happens to the SUMA object. SUMA doesn’t crash and everything else seems to be running properly, aside from this thresholding issue

Thanks for your help!

Can you provide a screenshot of your SUMA window + controller?

And what is the output of

3dinfo -min -max NIML_DSET

for the dset you are overlaying, and which sub-brick are you thresholding, and with what value?


I’ve attached the suma window and volume controller screen shot as well as the code I ran to open suma. As you can see it’s not a dset that we opened in suma but a volume. We’ve used this for volumes in the past and have been able to threshold the surface


I see-- you are viewing slices in the 3D space, and hten clicking the the “v” button under Volume Rendering Controls to interpolate/render the surface dset.

I just tested this out on a dset from the bootcamp, and indeed, there does seem to be some odd behavior on a Mac (10.14.6) that I have to use because I am traveling. In this case, only the coronal slices were being actually thresholded, while sag+axi ones weren’t, which I could tell if I unclicked that ‘v’. However, on a Linux machine, the thresholding behavior was working as expected.

I will guess you are using a Mac…?

So, sorry, I think this is some bugginess or problem with the Mac interface (sigh). We will have to look into it. In the meantime, if you have a Linux machine available, things should work.


Hmmm. This is working for various datasets I just tried on my desktop iMac with 10.14.6. Patrick, could you send me an example dataset?