@SUMA_Make_Spec_FS libraries error (again)


I’m using Mac OSX (Sierra) and I had the problem that’s been mentioned before, where @SUMA_Make_Spec_FS hits a library error. I followed the instructions to disable SIPS using csrutil, and all worked fine.

However, last week I updated my afni binaries (using @update.afni.binaries) and then I received the same error when running @SUMA_Make_Spec_FS, that is:

-- running 'mris_convert lh.smoothwm lh.smoothwm.asc'
dyld: lazy symbol binding failed: Symbol not found: ___emutls_get_address
  Referenced from: /Applications/freesurfer/bin/../lib/gcc/lib/libgomp.1.dylib
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: ___emutls_get_address
  Referenced from: /Applications/freesurfer/bin/../lib/gcc/lib/libgomp.1.dylib
  Expected in: /usr/lib/libSystem.B.dylib

failure: could not create surface lh.smoothwm.asc

--> is your FreeSurfer license installed?
program failure: exiting...

I checked that SIPS was still disabled, and it was, (but I ran the disable again just to be sure), but even after this I got the same error using @SUMA_Make_Spec_FS.

So then I went back to my old afni binaries using @update.afni.binaries -revert, which took me back to AFNI version=AFNI_17.0.16 (Mar 21 2017) [64-bit]. Using the old binaries @SUMA_Make_Spec_FS runs fine again, so I’ll leave it as is for now. Can you please let me know when this is fixed and I should try updating my binaries again?


This is what FreeSurfer’s wiki says about this error :

To resolve the issue, source freesurfer and then type the following command to update your installation:
sudo -E fs_update
If you have custom freesurfer scripts (that call freesurfer binaries) which you have written yourself, your script will need to include the following line somewhere near the top:
source $FREESURFER_HOME/sources.sh (bash)

source $FREESURFER_HOME/sources.csh (csh)

So do those couple things. Try adding the source line above to the @SUMA_MakeSpecFS script, and let me know if that works.