SUMA label font colour matching background

Hi everyone,

I am suddenly having a strange problem with SUMA. The crosshair labels are now the same colour as the background. I tried to change the background colour to white but the label colour also changed to white. I couldn’t find anything in .sumarc file that could be related to the label colour. I included screenshots to illustrate the issue. Any help would be appreciated.


That is weird. Can I ask what the output of:

afni -ver

is, to see both the AFNI version and the operating system being used? And is this a recent change on your system?

I just checked on my computer (Ubuntu 20.04), and things look OK.

There is a variable in the ~/.sumarc for label colors:

// 083-SUMA_Classic_Label_Colors:
//     Colorize labeled datasets without attempting to make colors match
//      what would be displayed in AFNI (YES or NO). Set to YES to match
//      old style colorization preceding the addition of this variable
//     default:   SUMA_Classic_Label_Colors = NO
   SUMA_Classic_Label_Colors = NO

… but changing that to YES didn’t have any effect on my system.


I’m not seeing this problem either. What platform - hardware and operating system are you using?

Those labels are the “crosshair labels” that appear usually above the surfaces in suma. You can switch the default coloring from a white font with black shadows to a black font with white shadows with the F6 key to switch the background color. You can also change the font with this suma environment variable in your .sumarc file.

// 059-SUMA_CrossHairLabelFont:
//     Font for cross hair label in SUMA viewer
//      Choose one of: f8 f9 tr10 tr24 he10 he12 he18
//     default:   SUMA_CrossHairLabelFont = f9
   SUMA_CrossHairLabelFont = he18

If you are missing the font indirectly named by these abbreviations, then I think you should see an error in the terminal. Trying another font might work then. You may need to reinstall these X11 fonts. That’s OS dependent, so you might need to do something like:

sudo apt-get install -y  xfonts-base xfonts-100

or this larger list of fonts:

sudo apt-get install xfonts-base
sudo apt-get install xfonts-misc
sudo apt-get install xfonts-100dpi
sudo apt-get install xfonts-biznet-100dpi
sudo apt-get install xfonts-biznet-75dpi
sudo apt-get install xfonts-75dpi
sudo apt-get install xorg-x11-fonts-misc

And then restart your computer.

Thank you for the information. Sorry for the slow response, I picked up a pretty bad cold for the last few days (luckily not covid).and have been a little out of it. I am running afni on ubuntu 20.04. What is really weird is when I change the background colour to white, the crosshair labels also become white. I have tried changing the fonts in .sumarc but no luck. I will try installing X11 fonts and see if that works.

Hmm, weird, because the Ubuntu setup tends to be pretty stable…

Just to doublecheck, can you perhaps make sure that all dependencies are present, by copy+pasting these commands:

sudo apt-get update

sudo apt-get install -y tcsh xfonts-base libssl-dev       \
                        python-is-python3                 \
                        python3-matplotlib python3-numpy  \
                        gsl-bin netpbm gnome-tweak-tool   \
                        libjpeg62 xvfb xterm vim curl     \
                        gedit evince eog                  \
                        libglu1-mesa-dev libglw1-mesa     \
                        libxm4 build-essential            \
                        libcurl4-openssl-dev libxml2-dev  \
                        libgfortran-8-dev libgomp1        \
                        gnome-terminal nautilus           \
                        gnome-icon-theme-symbolic         \
                        firefox xfonts-100dpi             \
                        r-base-dev cmake                  \
                        libgdal-dev libopenblas-dev       \
                        libnode-dev libudunits2-dev       \

which come from here:


Hi everyone,
After trying a million things I was finally able to resolve this issue although I am not sure if it is the best solution long term. The system I am using has a 3090 GPU installed. At some point, I started using nvidia 515 proprietary drivers and that seems to be what’s causing the issue. I switched to the open source drivers and the suma GUI works as normal. In hindsight, I probably should have suspected it was an issue with the driver right from the start.

OK, thanks for working through that and for letting us know.


Thank you for your help as well!