rPkgsInstall -pkgs ALL command not found

rPkgsInstall -pkgs ALL command not found

I am getting this error ,When I give above command on CentOS 7. Please guide me where to check and how to fix this.

Thank you.

Please provide the output of:

afni_system_check.py -check_all


When I run that, I got the reply like bash: afni_system_check.py -check_all: command not found

As per your other post, I don’t think you have refreshed your terminal by sourcing shell RC file-- in your case, it appeared to be a bash shell, so by doing:

source ~/.bashrc

Or, you could try opening a new terminal.



I followed the link [afni.nimh.nih.gov/pub/dist/doc/htmldoc/background_install/install_instructs/steps_linux_Fed_RH.html]

sudo yum install -y epel-release
sudo yum install -y tcsh libXp openmotif gsl xorg-x11-fonts-misc
PyQt4 R-devel netpbm-progs gnome-tweak-tool ed
libpng12 xorg-x11-server-Xvfb firefox
sudo yum update -y

curl -O https://afni.nimh.nih.gov/pub/dist/bin/linux_ubuntu_16_64/@update.afni.binaries
tcsh @update.afni.binaries -package linux_centos_7_64 -do_extras

export R_LIBS=$HOME/R
mkdir $R_LIBS
echo ‘setenv R_LIBS ~/R’ >> ~/.cshrc
echo ‘export R_LIBS=$HOME/R’ >> ~/.bashrc
. ~/.bashrc

complete the all above steps without errors

when I run rPkgsInstall -pkgs ALL , I am getting the error.


I am sorry, I signed out completely and signed back in… still same error.

When you log back in, are you logged in as root? Or as a separate user?

You can type “whoami” in a terminal to see who you are on the machine.


Is your user account login as “root”? If not, “cd” should take you to your user home directory, and your abin would be put there (not in /root/, where, again, it probably should not live).


Hi Taylor,

I have only three accounts on the machine

  1. root login
  2. shiva ( i have sudo privileges)
  3. imt

I am trying the installation using my account i.e shiva

Thank you.

Then I wonder if the problem is having abin under /root/ while you are logged in as a different user.

I think the abin under root should be removed (and be VERY careful if you use wildcards to do this!!! one reason not to put abin under /root…).

Then follow the normal AFNI setup instructions, and install/put abin under your home directory (probably /home/shiva):

curl -O [https://afni.nimh.nih.gov/pub/dist/bin/linux_ubuntu_16_64/@update.afni.binaries](https://afni.nimh.nih.gov/pub/dist/bin/linux_ubuntu_16_64/@update.afni.binaries)
tcsh @update.afni.binaries -package linux_centos_7_64 -do_extras

In doing the above command, after “cd”, you can type “pwd” to make sure you really are in your home directory-- “pwd” tells you your present working directory-- before doing the next commands.


Thank you Taylor for clarification. I will follow your instruction. I will try to do fresh installation and will get you back.

Thank you

i'm so sorry,but i'm still get the same wrong you get

Could you share the following information?

  • Computer OS
  • AFNI version information: afni -ver
  • The output of the following command: afni_system_check.py -check_all

Gang Chen

Perhaps your login shell is zsh. Would you please report the output from:

~/abin/afni_system_check.py -check_all

Adding the path to it should help in this case.

  • rick