Re: AFNI GUI crash after click the Draw Dataset

Split from this thread:,162493,162493#msg-162493
because it is the start of a new discussion, and so easier to follow afresh.


Dear Afni Team,

I am writing because I am new on afni and I encountered the same problem when I try to open the draw dataset plugin through afni GUI. This is the error that is displayed:

++ NOTE: This version of AFNI was built Jun 14 2016 ++
++ NOTE: ‘Define Markers’ is hidden: right-click ‘DataDir’ to see it
** ERROR: No atlas named MNI_Glasser_HCP found in global atlas list
** ERROR: No atlases given were found in global atlas list
Please see whereami help and AFNI_atlas_spaces.niml for information
on how to add atlases to AFNI

Fatal Signal 11 (SIGSEGV) received
Last STATUS: ** free() of non-tracked pointer [thd_ttatlas_query.c line 8577] ??
Bottom of Debug Stack
** AFNI version = AFNI_16.1.24 Compile date = Jun 14 2016
** [[Precompiled binary linux_openmp_64: Jun 14 2016]]
** Program Death **
** If you report this crash to the AFNI message board,
** please copy the error messages EXACTLY, and give
** the command line you used to run the program, and
** any other information needed to repeat the problem.
** You may later be asked to upload data to help debug.
** Memory usage: chunks=57631 bytes=33760991
** Crash log is appended to file /home/pbinda1/.afni.crashlog

This error appeared after I tried to install the atlas named MNI_Glasser_HCP. Reading the previous comments I tried to see what came up by typing in the terminal “whereami -show_atlases” and all atlas appear, including MNI_Glasser_HCP, while if I type @AfniEnv -get AFNI_ATLAS_LIST
nothing comes up.

Another thing, because I found it in another post, is that I tried looking to see if the atlas I added is present in the AFNI_atlas_spaces.niml file and indeed it does not appear.

Can you help me solve the problem?

Thank you very much,

Hi, Alessia-

To start, what is the output of: -check_all

on your system?


I will note this version of AFNI is nearly 5 years old according to the version output at the beginning of this message. There may be two versions of AFNI in the path, but the one that is being run is fairly out of date, so an upgrade is warranted.