Problem with command scripts

when I run
tcsh OS_notes.linux_ubuntu_20_64_c_nice.tcsh 2>&1 | tee o.ubuntu_20_c.txt
I get this error message:

export: Command not found.
++ Set up tab autocompletion for tcsh
++ Make t/csh aliases for colorful listing of files/dirs: ls, ll, ltr
++ Make bash aliases for colorful listing of files/dirs: ls, ll, ltr
++ Done with niceifying terminal part

I had no problem with the previous command scripts, I am not sure why I get 'command not found'.


I guess you are using a bash shell terminal, from the syntax there. To verify, could you please run this and copy+paste the output?

echo $0

There is no "export" in that script, so I assume that somehow an unhappy export is stuck in one your shell's ~/.*rc file, which again I am guess is ~/.bashrc. I'll email you for your dot files, and take a look.


Thank you, echo $0 confirmed it is a bash shell.


Thanks for sending those files. I believe that the issue is that there is an export statement in the ~/.cshrc file. The csh (and tcsh) don't use export, they use setenv.

So, can you open up that file on your computer---here is an example of opening it up with a default text editor, but you can use whatever program you want (and note both the tilde ~ and dot .):

afni_open -e ~/.cshrc

... and change:

export DISPLAY=:0.0


setenv DISPLAY :0.0

NB: the spacing is important.

After that, please open a new terminal, and there should be no messages or anything.

You can also check that if you enter tcsh mode---by typing tcsh---that there should be no messages (and you can exit that by typing exit when done).


Thank you, I made the changes as per your instructions. Typing tcsh there are no messages and when I run the script it only shows me this message:
Thank you for your help!

Great, that seems good to go.