Problem with 3dSkullStrip

Hello everyone I have a problem with 3dSkullStrip command. Whenever I run this command, I have the following error:

3dSkullStrip: error while loading shared libraries: cannot open shared object file: No such file or directory

I tried to solve this by uninstalling and reinstalling the gsl-bin but it is not effective :frowning:


What system are you using, and what is the output of “afni -ver”?


Hi pt
Precompiled binary linux_openmp_64: Jan 3 2017 (Version AFNI_17.0.00)

Hi, Peyman-

So, you are on Linux, but what flavor+version: for example, Ubuntu 14.04 or 16.04? Or Fedora, Redhat, …?


Hi pt-
Ubuntu 16.04.2 LTS xenial

OK, that explains the problem. The current Linux notes are mainly for Ubuntu 14.-15.. In 16.04, some locations of files change (even though the same package manager, aptitude, is running the show).

Can you please run this to find out where your GSL library in question is:

find /usr/lib -name "libgsl*"

That should give you something like file location that looks like:


(where the “/usr/lib/x86_64-linux-gnu/” is pretty sure to be there, and I don’t know if the last part, the specific library name, will be exactly that-- but likely it will be?) Note: there may be other files returned by the find command.

IF that does show that file location, then you can make link to it with this, so that your system will be able to find the library in question:

sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/

(The second path in that command is where your system will look for the library, and the first path is the actual location on your system where it will be redirected to find that file.)

… and then what is the output of your about that?


Thanks a lot for all of your support it. :)-D
I had the “” and the this command solved it

sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/


Rockin’, glad that worked.


On a similar note, I recently had to do this for Fedora 25.

sudo ln -s /usr/lib64/ /usr/lib64/