Problem running drivers on Sierra

Ever since I upgraded to the Mac OS Sierra, when I run @ss_review_driver scripts, all of the windows open at the same time, rather than the program only advancing once ‘OK’ is clicked in the dialog boxes. Based on what I’ve read in other threads, I downgraded XQuartz from 2.7.11 to 2.7.9, which fixes the error warnings that I get when I run afni_system_check (when I had XQuartz 2.7.11 installed, it said that I needed to put “export DYLD_LIBRARY_PATH=/opt/X11/lib/flat_namespace” in my .bashrc even though this line was already in the .bashrc; this no longer happens with XQuartz 2.7.9).
This issue has happened on two different machines, so I think it has something to do with using XQuartz in more recent versions of Sierra (I am using 10.12.3). Any advice on what might be causing this?

Hi Jeff,

This is still almost surely a result of not having that set right.
You are running bash, is that correct? Show “echo $0” to be
sure. What is your AFNI version (afni -ver)?

Perhaps more importantly, you need to have this set up for
tcsh as well, which means setting that environment variable
in your home .cshrc (or .tcshrc) file. The driver script is run
via tcsh.

  • rick

Thanks Rick! Modifying the .cshrc worked. Just so others don’t run into this problem, I might recommend changing the AFNI installation notes for Mac OS to suggest that both the .cshrc and the .bashrc need to have DYLD_LIBRARY_PATH adjusted (right now, step 1b says that either bash or tcsh syntax can be used, which is where I ran into a problem).
Thanks again for your help!