polort warning with 3dDeconvolve with 1 Run of fMRI task event-related data

I keep getting this warning when trying to run 3dDeconvolve on one run of fMRI data:
*+ WARNING: Input polort=1; Longest run=514.8 s; Recommended minimum polort=4

I got this initially when I set “-polort A” but have since changed it to “-polort 4” as per the recommended minimum. I’ve been able to successfully run 3dDeconvolve with a two run version of the task and using “-polort A”, but keep getting this warning when running 3dDeconvolve on only 1 run. My script is pasted below.

3dDeconvolve -global_times
-input ${OUT_DIR}/scale_blur_fMRI_REW1.nii.gz
-polort 4
-num_stimts 8
-stim_times 1 ${IN_DIR}/TrialOnset_oneLine.txt ‘GAM’ -stim_label 1 TrialOnset
-stim_times 2 ${IN_DIR}/Win_oneLine.txt ‘GAM’ -stim_label 2 Win
-stim_times 3 ${IN_DIR}/Lose_oneLine.txt ‘GAM’ -stim_label 3 Lose
-stim_times 4 ${IN_DIR}/Mixed_oneLine.txt ‘GAM’ -stim_label 4 Mixed
-stim_times 5 ${IN_DIR}/Neutral_oneLine.txt ‘GAM’ -stim_label 5 Neutral
-stim_times 6 ${IN_DIR}/Reward_oneLine.txt ‘GAM’ -stim_label 6 Reward
-stim_times 7 ${IN_DIR}/Loss_oneLine.txt ‘GAM’ -stim_label 7 Loss
-stim_times 8 ${IN_DIR}/None_oneLine.txt ‘GAM’ -stim_label 8 None
-ortvec ${IN_DIR}/motion_demean.1D movregs
-num_glt 11
-gltsym ‘SYM: Win -Lose’ -glt_label 1 Win-Lose_Cue
-gltsym ‘SYM: Win -Mixed’ -glt_label 2 Win-Mixed_Cue
-gltsym ‘SYM: Win -Neutral’ -glt_label 3 Win-Neutral_Cue
-gltsym ‘SYM: Lose -Mixed’ -glt_label 4 Lose-Mixed_Cue
-gltsym ‘SYM: Lose -Neutral’ -glt_label 5 Lose-Neutral_Cue
-gltsym ‘SYM: Mixed -Neutral’ -glt_label 6 Mixed-Neutral_Cue
-gltsym ‘SYM: Reward -Loss’ -glt_label 7 Reward-Loss_Outcome
-gltsym ‘SYM: Reward -None’ -glt_label 8 Reward-None_Outcome
-gltsym ‘SYM: Loss -None’ -glt_label 9 Loss-None_Outcome
-gltsym ‘SYM: 0.25Win +0.25Lose +0.25Mixed +0.25Neutral’ -glt_label 10 MEAN_Cue
-gltsym ‘SYM: 0.3334None +0.3333Reward +0.3333*Loss’ -glt_label 11 MEAN_Outcome
-tout -fout -nobout
-x1D “${STATS_DIR}/${subj}/X.xmat_firstblock.1D” -xjpeg “${STATS_DIR}/${subj}/X_firstblock.jpg”
-cbucket ${subj}coeffs_REW_firstblock.nii.gz
-bucket “${STATS_DIR}/${subj}/${subj}stats_REW_firstblock.nii.gz”

Thank you,

Hi Brent,

There is no line continuation after your input dataset, so
3dDeconvolve is probably missing the entire rest of the
options. Is expect the shell also complains about -polort,
no such command.

Anyway, that seems to be why it does not see your
-polort 4 option.

  • rick