pass word in AFNI container

Hi guys,

I have followed the instructions on the official website,
and install the AFNI with docker.
However, seems that I need a password if I would like to install something in the container.
Is that someone who experienced the same situation?

 sudo sh -c 'echo "deb focal-cran40/" >> /etc/apt/sources.list'
[sudo] password for afni_user: 
Sorry, try again.
[sudo] password for afni_user: 

I have tried my host password, but failed.
Thanks in advance!


Hi, Weijian-

I have to start by admitting ignorance in many things related to Docker containers.

I think docker exec ... can be used to run commands within a container, as described here. But I have not tried to edit a Docker environment as a user.

Can I ask what you would like to edit about the Docker?

Please note that our currently distributed Dockers containers are woefully out of date, like almost a year old. We are in the process of majorly overhauling the way we create+distribute them. I would hope to have these available relatively soon, but I am not certain when it will be.


Hi Ptaylor,

Thanks! I have entered the container using docker exec.
Then I tried to install a newer version of R to facilitate the further installation of 'bmrs', as well as the installation of 'cmdstanr' and 'cmdstan'.
According to this page (AFNI program: RBA), I should need these.
But it seems that not all servers can be installed smoothly, so I want to try to implement this in docker.