Overlay Threshold Gray Fading

Hi All,

A while ago, I used to be able to perform threshold fading; i.e. through overlay and thresholding, I could see in the graph window some boxes as white and others as gray. For the life of me, I can no longer figure out how to do this. Below are my attempts to resolve this:

(0) Updated afni. (output from >afni -ver:
Precompiled binary macos_10.12_local: Aug 4 2020 (Version AFNI_20.2.10 ‘Aulus Vitellius’)
(1) included ‘AFNI_GRAPH_FADE = YES’ in my ~/.afnirc
(2) Try numerous variations of threshold values, and using the hotkey ‘F’ to engage the fading option
(3) Watched numerous of the new youtube videos to see if I could find anything addressing this.
(4) Try toggling different settings to get it working.

Unfortunately, all to no avail. Attached is a screen shot of my workspace. I have data sets loaded to both Underlay and Overlay, and thresholding seems to work fine. But the fading doesn’t. I do seem to recall I had to do some trick to get it working in the past, but cannot remember what that trick was. This was a very helpful setting in analyzing data and I would very much like to re-engage with it. Any help would be greatly appreciated. Thank you.


Hi, Edwin-

Have you tried using the ‘A’ and ‘B’ buttons at the top of the controller, just to the right of ‘Thr’? These provide “alpha” and “boxed” functionality when thresholding-- it is described in this AFNI Academy/Bootcamp video here (should be at about 16:20 in the video):
… in the description of thresholding over the next couple of minutes there, does that accomplish what you want?

And see Ex 5 here:
(and any others with ‘alpha’ in them) to see how to control this same features in automatic image generation with @chauffeur_afni.


Thank you very much for your prompt response. Yes, I have tried that and it doesn’t engage a gray background in the graph window as I desire. I’ve attached another screen shot that I took a while ago of what I’m trying to re-create. Maybe I’m targeting the wrong function to enable this. Any insight into how to do this would be greatly appreciated.

Thank you,

Oohhh, right, I totally misunderstood-- sorry about that.

You are referring to the “AFNI_GRAPH_FADE” functionality, which Bob described here:

I also see that it doesn’t work on my computer, even if I explicitly set “AFNI_GRAPH_FADE = YES” in teh ~/.afnirc (which shouldn’t be necessary now…).

I will ping The Bob about this…


ps: and in the lower left of the Graph viewer, I even see the word “Fading” (just to the left of the red text below the graphs), but I don’t see the fading behavior occurring :frowning:

Thank you for looking into it :slight_smile: Yes, that confused me as well. It seems to be able to successfully toggle the function (the word ‘Fading’ will appear and disappear) but nothing else happens in the graph window. Thank you!


Good Morning!

Curious if there was any resolution to this issue? Thanks!


After Paul poked me, I looked at this problem. It has been fixed in the source code, and should be fixed at the next AFNI binary build (soon).

The issue came from the addition of the “A” (alpha) fading of the colorized overlay images, made in early 2020. The Fading of graphs was introduced in 2013. I failed to realize the interaction between these two features until now. Either my brain is failing, or the AFNI code is getting more complex. Or both.

No worries! Thanks so much for looking into it. Very grateful and look forward to the next build. Haha, no doubt the complexity. All the best!


I just started a build, so in a couple hours you should have the new functionality if you update AFNI:

@update.afni.binaries -d


Hi Paul,

Thank you. So I did the update and am looking at it now. Unfortunately, it still doesn’t seem to work. Does it work properly on your terminal? Unless the build hasn’t finished yet and thus isn’t the correct updated version…


Hi, Edwin-

Sorry, I just tried on the most uptodate version (Version AFNI_20.2.12 ‘Aulus Vitellius’) for linux_ubuntu_16_64, and fading doesn’t appear to work. Will have to check back with Bob about this…


Hi, Edwin-

Sorry for the confusion-- a minor github mishap on our end, which has been resolved.

The updated code should be in the current build, which I just started, so in a few hours from now, you should be to have the graph fading functionality back in your AFNI GUI.

Fingers crossed…


Hi, Edwin-

… And I can confirm (see attached image) that the AFNI Graph Fading is back in action with the latest binaries:
Aug 19 2020 (Version AFNI_20.2.13 ‘Aulus Vitellius’)


Huzzah! It works on mine as well. I would like to extend my sincerest gratitude for all the help with this. I’m sure it may be something small but it is super helpful for me with analysis. Thank you so much!!