New install question

Hi, I am doing a new install on MacOS. Here is the result of the check: -check_all
-------------------------------- general ---------------------------------
architecture: 64bit
system: Darwin
release: 16.7.0
version: Darwin Kernel Version 16.7.0: Wed Apr 24 20:50:53 PDT 2019; root:xnu-3789.73.49~1/RELEASE_X86_64
distribution: 10.12.6 x86_64
number of CPUs: 4
apparent login shell: bash
shell RC file: .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /Users/greenlab/abin/afni
afni version : Precompiled binary macos_10.12_local: Jun 19 2019
: AFNI_19.1.22 ‘Caligula’
AFNI_version.txt : AFNI_19.1.22, macos_10.12_local, Jun 19 2019
which python : /usr/bin/python
python version : 2.7.10
which R : /usr/local/bin/R
R version : R version 3.4.1 (2017-06-30) – “Single Candle”
which tcsh : /bin/tcsh

instances of various programs found in PATH:
afni : 1 (/Users/greenlab/abin/afni)
R : 1 (/Library/Frameworks/R.framework/Versions/3.4/Resources/bin/R)
python : 1 (/usr/bin/python)
python2 : 0
python3 : 0

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : success : success
3dAllineate : success
3dRSFC : success
SurfMesh : success
3dClustSim : success

checking for R packages…
rPkgsInstall -pkgs ALL -check : FAILURE

    oo Warning: 
       These packages are not installed on the computer: brms!

checking for $HOME files…
.afnirc : found
.sumarc : found
.afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** python module not found: PyQt4
– PyQt4 is no longer needed for an AFNI bootcamp

-------------------------------- env vars --------------------------------
PATH = /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Users/greenlab/abin

DYLD_LIBRARY_PATH (sub-shell) = :/opt/X11/lib/flat_namespace

------------------------------ data checks -------------------------------
data dir : found AFNI_data6 under $HOME
top history: …2019 [ptaylor]: updated FT_analysis/results.QC_FT.05
data dir : found AFNI_demos under $HOME
top history: 29 Apr 2019 [rickr]: AFNI_pamenc command newline
data dir : found suma_demo under $HOME
top history: …s_New/data/Build_tmp on Mon Mar 4 11:56:45 EST 2013
data dir : found afni_handouts under $HOME
atlas : found TT_N27+tlrc under /Users/greenlab/abin

------------------------------ OS specific -------------------------------
which brew : /usr/local/bin/brew
brew version : Homebrew 2.1.6

– for PyQt4 under brew, consider running:
brew install cartr/qt4/pyqt
– consider installing gcc under homebrew
– consider installing glib under homebrew
++ found 1 dylib files under ‘/opt/X11/lib/flat_namespace’
– found ‘libXt’ dylib files:
– recent OS X, cheating to check DYLD_LIBRARY_PATH in cur shell ‘bash’…
++ found evar DYLD_LIBRARY_PATH = :/opt/X11/lib/flat_namespace
– recent OS X, cheating to check DYLD_LIBRARY_PATH in shell ‘tcsh’…
++ found evar DYLD_LIBRARY_PATH = /opt/X11/lib/flat_namespace

========================= summary, please fix: =========================

  • login shell ‘bash’, trusting user to translate code examples from ‘tcsh’
  • missing R packages (see rPkgsInstall)

However, when I run: rPkgsInstall -pkgs ALL

++ Note: @ 10:56:01
This package has been installed on the computer: brms

Warning message:
package ‘brms’ is not available (for R version 3.4.1)

Do I need the brms package? Or should I install a different version of R?

Thank you in advance for your help!


Yes, you should update your version of R; I’m not sure why we link to that old one still, and I will update our instructions. This should be a modern enough version to use (3.5.3) on Macs:
(form the cran website, having 3.6.0 might require other installs to compile R libraries).

After updating your R, you should update your packages in the R, by running the following in the R environment:

update.packages(installed.packages(priority="NA"), checkBuilt=TRUE, ask=FALSE)

After that, you can then run the AFNI rPkgsInstall program to get the remaining brms package:

rPkgsInstall -pkgs ALL


Excellent, that fixed it. Thanks!