Missing parts of the cortex in @SSwarper results

Hi experts,

I run @SSwarper before afni_proc. For most of the participants, the results are good. But for 7 of them, the results missed some parts of the cortex.

For example, one of the participants results:
Screen Shot 2023-06-22 at 4.04.24 PM

The input looks good:

The init_QC01 and init_QC02 look like missed part of the cortex.

The AFNI version info (afni -ver): Precompiled binary macos_10.12_local: May 30 2023 (Version AFNI_23.1.07 'Publius Helvius Pertinax')

The code:

@SSwarper \
	-input "$i".T1.padded180.nii \
	-base TT_N27_SSW.nii.gz \
    -subid  "$i" 

Could you please help? Thank you in advance!


i'd also be interested in what the experts think about this. i myself have found that if SSwarper doesn't perform super well (usually it does!) it's in that superior parietal region. if you add something like -SSopt -push_to_edge to your SSwarper command that could help but maybe the true experts have other recommendations

Thank you for your suggestion. I tried -SSopt '-o_ply Fred.Is.Wonderful' but it did not work. -push_to_edge is not an option of @sswarpper. But from the help file of 3dSkullStrip, I think it might be helpful if it could be set for @sswarpper.

Hi @ptaylor,
Do you have any suggestion? Is it possible to set the parameters similar to -push_to_edge for sswarpper? Thanks!


hi Xiyue

in your SSwarper command you have to type "-SSopt -push_to_edge" all together like that.

SSopt is like a little 'doorway' into directly controlling 3dskullstrip. actually AFNI has a lot of that, part of what makes it so awesome. for example type
"afni_proc.py -show_valid_opts | grep _opts" and you'll see many similar doorways within the afni_proc castle ;-)

in any case, I'm still interested in what Paul and the other real experts might suggest, but for now you know you can still try that. cheers

Hi storrisi,

Thank you for your help! I tried "-SSopt -push_to_edge" and the results are better!
For the same participant, in the left figure, the results covered the whole brain. But in the right figure, the results did not change.
Also, thank you for the information of "doorway". I didn't know that before. It seems that @SSwarpper has no -show_valid_opts parameters. Can I set the -SSopt to push more to the edge? Do you have suggestions?

Screen Shot 2023-08-23 at 11.27.42 AM

Hi all,

We are having an almost identical issue. We have tried push to edge and unifize off, but neither have worked.

Have there been any solutions?

How about trying the newer sswarper2, which is an update to @SSwarper? It is now distributed in the very latest version of AFNI if you update your local version. The syntax of it is essentially the same as with @SSwarper, as is its outputs.

Or, you can go to where your AFNI binaries are, and run:

curl -O https://raw.githubusercontent.com/afni/afni/master/src/scripts_install/sswarper2
chmod 755 sswarper2

The first line downloads the file, and the second makes it executable, so it will run like a normal program.


just to hop back on here; i compiled the newest yesterday and compared @SSwarper with sswarper2 on a 3T MPRAGE and a 7T MP2RAGE (the latter background-noise-suppressed) and, while it's not a large comparison, first impressions are sswarper2 is an improvement! takes a little longer but that's ok for me when i'm not testing. thanks, Paul!