MEICA: fails on 3dTshift for -tpattern @filename

I am using MEICA on data with 3 echo times, TR of 1553. I ran into 2 problems, maybe related.

AFNI version is 16.3.00 (Oct 9 2016)

I ran the command: -e 12.4,34.28,56.16 -d 4D_TE1.nii,4D_TE2.nii,4D_TE3.nii -a mp2rage.nii -tpattern @/mnt/NAS5/toolbox/labtools/sliceorder.txt --MNI --qwarp --TR=1.553 --OVERWRITE

and the shell script ran fine until this point:

echo +* “Preliminary preprocessing of functional datasets: despike, tshift, deoblique, and/or axialize”
echo --------“Preliminary preprocessing dataset 4D_TE1.nii of TE=12.4ms to produce e1_ts+orig”
3dDespike -overwrite -prefix ./4D_TE1_pt.nii.gz 4D_TE1.nii
3dTshift -heptic -tpattern @/mnt/NAS5/toolbox/labtools/sliceorder.txt -prefix ./e1_ts+orig ./4D_TE1_pt.nii.gz
3daxialize -overwrite -prefix ./e1_ts+orig ./e1_ts+orig

3dTshift fails because the script does not include the TR in the argument (I think). Because the slice order text file includes values larger than 1.0 s, it fails. (Illegal value 1.108 in tpattern file /mnt/NAS5/toolbox/labtools/sliceorder.txt). Would probably be better if 3dTshift included a -TR argument if it was included in the command line?

I can manually correct this by adding the -TR 1.553 to the 3dTshift line in the shell script. But the output is written as e1_ts+tlrc, and not e1_ts+orig, and the next step (3daxialize) fails: FATAL ERROR: Can’t open input dataset: ./e1_ts+orig

Even if I change the name of the file from e1_ts+tlrc to e1_ts+orig, afni still can’t open the input dataset (but if I convert this to a nifti file and open it in SPM it looks fine to me and is aligned in original space rather than talairach space.) I could change the script to keep using +tlrc instead of +orig throughout (which works), but would rather not have to manually edit the scripts for each case.

Do I have a setting wrong somewhere in AFNI that defaults to tlrc files?

There seem to be 2 issues then. One is that the
sform_code/qform_code values are 2 (which has become
ambiguous because of improper usage). To treat those
as orig space, set AFNI_NIFTI_VIEW to orig (in your
.afnirc file, or perhaps the shell).

Also, if the TR is 1.0 s for some reason (i.e. it is
incorrect), fix it before proceeding.

What does “3dinfo 4D_TE1.nii” show, for example?
Does it show “Time step = 1.00000s”?

If so, just fix it: 3drefit -TR 2 4D_TE1.nii .

  • rick

Thank you - running beautifully now.