M1 Mac Install failure

Hello all,

I would be truly grateful for your prompt guidance. I see that others (@AnnaX , @elif , @menonsn ) have posted to this message board about similar issues with installing on Apple Silicon M1.

I’m running on macOS Monterey 12.7.2.
python version 3.9.15 under anaconda3
I do have administrative privileges.
I am not enrolled in an AFNI bootcamp.

To confirm, I have repeatedly followed the quick setup instructions for general users posted on the AFNI installation website:

When I completed the last step (E.), opened a new terminal and ran:
afni_system_check.py -check_all
I got a long output terminating in this:
setenv: Too many arguments.
Now when I run this again ( afni_system_check.py -check_all ), I get "command not found."
Running this produces no file: afni_system_check.py -check_all > out.ASC.txt

I’d be grateful for help. Please let me know what to try or if you want to see my hist_commands.txt or hist_messages.txt.

Many thanks.


There is probably just something messed up in your .cshrc or .tcshrc file.
Would you please run

afni_system_check.py -dot_file_pack my_dotfiles.tgz

I will send you a private message where to mail the resulting my_dotfiles.tgz file.

  • rick

Thank you for replying so quickly, Rick. I ran that command and got command not found. Any ideas?


Oh my, I must be tired. Does it work with a path?

~/abin/afni_system_check.py -dot_file_pack my_dotfiles.tgz

Otherwise, I will just give you a few commands.

  • rick

Just sent to .tgz to your gmail. Thanks.

A huge thank you to Rick for helping me debug this byzantine problem.

One part of the issue was a conflict with my conda install.

Hi a.v. and rick,
I have the same issue. Have you guys figured it out?



Hi Jai,

We resolved that via zoom in December, but I no longer recall what was necessary. But the main problem was probably conda interference with installing dependencies and then compiling.

Would you provide more details about what the problem is in your case? It might help for you to start with showing the output of:

~/abin/afni_system_check.py -check_all

What part of the install steps did you get through?

  • rick

Hi Rick and Jai,

That’s right, Rick. As I remember it, there was interference from my Conda installation. I believe that we had to remove Conda activation from my .bashrc file.

Just to follow up, when compiling the AFNI package, it is generally a good idea not to be in any conda environment (including base). That can cause the compiler to look for libraries in the wrong place. But once the compilation is finished it is generally okay to be in a conda environment when actually running the AFNI programs.

That is to say, when building/updating AFNI: deactivate, build, activate again.

  • rick