Installation: missing R Packages

Hello helpful people,

I am trying to install AFNI for the first time in my life. On Windows/WSL/Ubuntu

I followed instructions at faithfully (I think), but -check_all

========================= summary, please fix: =========================

  • missing R packages (see rPkgsInstall)


checking for R packages…
rPkgsInstall -pkgs ALL -check : FAILURE

    oo Warning:
       These packages are not installed on the computer: afex!
    These packages are not installed on the computer: phia!
    These packages are not installed on the computer: brms!

I tried to re-run rPkgsInstall -pkgs ALL just in case, but it did not solve the issue

Any suggestions?

(Also, I have no linux/unix experience whatsoever, so please be patient…)

I tried installing libcurl4-openssl-dev as suggested by isospin in the “brms not installed” thread.

This fixed the afex and phia problem, but brms is still reported not installed.

It looks to me that PKI fails to install due to lack of openssl (even though I did sudo apt-get install libcurl4-openssl-dev) and that leads to brms not installed through a chain of dependencies

Any idea how to fix this?

Here us what rPkgsInstall -pkgs ALL returned

  • installing source package ‘PKI’ …
    ** package ‘PKI’ successfully unpacked and MD5 sums checked
    checking for gcc… gcc -std=gnu99
    checking whether the C compiler works… yes
    checking for C compiler default output file name… a.out
    checking for suffix of executables…
    checking whether we are cross compiling… no
    checking for suffix of object files… o
    checking whether we are using the GNU C compiler… yes
    checking whether gcc -std=gnu99 accepts -g… yes
    checking for gcc -std=gnu99 option to accept ISO C89… none needed
    checking how to run the C preprocessor… gcc -std=gnu99 -E
    checking for grep that handles long lines and -e… /bin/grep
    checking for egrep… /bin/grep -E
    checking for ANSI C header files… yes
    checking for sys/types.h… yes
    checking for sys/stat.h… yes
    checking for stdlib.h… yes
    checking for string.h… yes
    checking for memory.h… yes
    checking for strings.h… yes
    checking for inttypes.h… yes
    checking for stdint.h… yes
    checking for unistd.h… yes
    checking openssl/ssl.h usability… no
    checking openssl/ssl.h presence… no
    checking for openssl/ssl.h… no
    checking openssl/rsa.h usability… no
    checking openssl/rsa.h presence… no
    checking for openssl/rsa.h… no
    configure: error: Failed to find usable crypto library. Please install openssl-dev or equivalent and/or set PKG_LIBS if not in default location.
    ERROR: configuration failed for package ‘PKI’
  • removing ‘/home/pawel/R/PKI’
    ERROR: dependency ‘PKI’ is not available for package ‘rsconnect’
  • removing ‘/home/pawel/R/rsconnect’
    ERROR: dependency ‘rsconnect’ is not available for package ‘shinystan’
  • removing ‘/home/pawel/R/shinystan’
    ERROR: dependency ‘shinystan’ is not available for package ‘brms’
  • removing ‘/home/pawel/R/brms’

From the sound of it you may need to install openssl and openssl-dev. Since you say you are using Ubuntu, you should be able to achieve this with

sudo apt-get install openssl openssl-dev

Note that openssl-dev and libcurl4-openssl-dev are not the same thing. the former is the development support part (e.g., the header files) of the library that provides SSL support. The latter iis the pat of the libcurl4 that provides developmental support for SSL in libcurl4. (Libcurl is the library behing the curl program). I confess, though, that I’m surprised that libcurl4-openssl-dev doesn’t automatically pull in openssl-dev.

I’ve not got an Ubuntu machine on which to try this out so bear that in mind when trying this.

Thank you. This did not help though, I got:
E: Unable to locate package openssl-dev

But someone else recommended
sudo apt-get install libssl-dev

and after that, and reinstallation of R, AFNI installation check return a yay!