Install Fail on Mac M3 --problem with gcc-13?

Hi, I followed all instructions located here: 1.1.8. macOS 12+ (Apple Silicon/ARM processor/chip: M1, M2, …) — AFNI, SUMA and FATCAT: v24.1.11

However, I am getting errors when attempting to run the last step:
tcsh OS_notes.macos_12_ARM_b_user.tcsh

I have read through most of the other threads that discussed similar issues, and tried some of the solutions posted there, including reinstalling homebrew files and then rerunning the build using: -build_root $HOME/afni_build -package macos_13_ARM_clang

In all cases things look okay until it gets to ++building (please be patient)...
Then I get the errors which generate the log_make.txt code pasted here:

/bin/cp -f niml/niml.h .
( /bin/cp -f AFNI_version_base.txt AFNI_version.txt ;
echo macos_13_ARM_clang >> AFNI_version.txt ;
date +'%b %d %Y' >> AFNI_version.txt ;
echo build >> AFNI_version.txt ;
echo "#undef AFNI_VERSION_LABEL" > AFNI_version.h ;
echo '#define AFNI_VERSION_LABEL "'cat AFNI_version_base.txt'"'
>> AFNI_version.h ;
echo "#undef AFNI_VERSION_PLATFORM" >> AFNI_version.h ;
echo '#define AFNI_VERSION_PLATFORM "'macos_13_ARM_clang'"'
>> AFNI_version.h ;
( cd niml/ ; make all 'CC=/opt/homebrew/bin/gcc-13 -arch arm64 -DDARWIN -DARM_M1 -O1 -m64 -Wall -Wno-deprecated-declarations -Wcomment -Wformat -DUSE_TRACING -DHAVE_XDBE -DDONT_USE_MCW_MALLOC ' ; /bin/mv -f *.o .. ; )
/opt/homebrew/bin/gcc-13 -arch arm64 -DDARWIN -DARM_M1 -O1 -m64 -Wall -Wno-deprecated-declarations -Wcomment -Wformat -DUSE_TRACING -DHAVE_XDBE -DDONT_USE_MCW_MALLOC -I../f2c -c niml_b64.c
make[1]: /opt/homebrew/bin/gcc-13: No such file or directory
make[1]: *** [niml_b64.o] Error 1
mv: rename .o to ../.o: No such file or directory
make: *** [niml_b64.o] Error 1

I am new to using a Mac and not really a coder so I have no idea what I'm doing, but I will just note that I was investigating whether or not the gcc-13 file truly does exist on my machine, and instead I found /opt/homebrew/bin/gcc-14. Any chance this could be causing the error? If so, how do I fix it? If not, any other suggestions?

Could you try this:

brew install gcc@13

Then repeat the installation script with

tcsh OS_notes.macos_12_ARM_b_user.tcsh

Woohoo! That seemed to work. Thanks so much!

1 Like

@dglen--This solved my issue, too. Thank you!

1 Like