Install AFNI on server


This is probably a very basic question. i am new to afni and using my university server. I am trying to run afni on OSC. i dowloaded the .tgz file (linux_openmp_64.tgz) and then unzipped it using tar zxvf linux_openmp_64.tgz. It created a new folder which has all these files, but if i enter the directory and press afni. i get an error. do i have to do something after that? i tried to type ./configure but got an error

Prateek Sasan

Hi Prateek,

If it is okay to do, would you please go into that same directory and run

cd linux_openmp_64
./ -check_all


  • rick

I get the following

-------------------------------- general ---------------------------------
architecture: 64bit ELF
system: Linux
release: 3.10.0-1062.18.1.el7.x86_64
version: #1 SMP Wed Feb 12 14:08:31 UTC 2020
distribution: Red Hat Enterprise Linux Server 7.7 Maipo
number of CPUs: 28
apparent login shell: bash
shell RC file: .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : which: no afni in (/usr/local/xalt/xalt/bin:/opt/mvapich2 /intel/19.0/2.3.3/bin:/usr/local/gnu/8.4.0/bin:/opt/intel/itac/2019.5.041/bin:/o pt/intel/advisor_2019/bin64:/opt/intel/vtune_amplifier_2019/bin64:/opt/intel/ins pector_2019/bin64:/opt/intel/compilers_and_libraries_2019.5.281/linux/bin/intel6 4:/usr/local/software_usage:/opt/torque/bin:/usr/lib64/qt-3.3/bin:/opt/osc/bin:/ opt/moab/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/opt/ibutils/bin: /opt/ddn/ime/bin:/opt/puppetlabs/bin)


AFNI_version.txt : AFNI_20.2.16, linux_openmp_64, Sep 02 2020
which python : /usr/bin/python
python version : 2.7.5
which R : which: no R in (/usr/local/xalt/xalt/bin:/opt/mvapich2/in tel/19.0/2.3.3/bin:/usr/local/gnu/8.4.0/bin:/opt/intel/itac/2019.5.041/bin:/opt/ intel/advisor_2019/bin64:/opt/intel/vtune_amplifier_2019/bin64:/opt/intel/inspec tor_2019/bin64:/opt/intel/compilers_and_libraries_2019.5.281/linux/bin/intel64:/ usr/local/software_usage:/opt/torque/bin:/usr/lib64/qt-3.3/bin:/opt/osc/bin:/opt /moab/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/opt/ibutils/bin:/op t/ddn/ime/bin:/opt/puppetlabs/bin)

which tcsh : /usr/bin/tcsh

instances of various programs found in PATH:

instances of various programs found in PATH:
afni : 0
R : 0
python : 1 (/usr/bin/python2.7)
python2 : 1 (/usr/bin/python2.7)
python3 : 1 (/usr/bin/python3.6)

testing ability to start various programs…
afni : FAILURE
/bin/sh: afni: command not found
suma : FAILURE
/bin/sh: suma: command not found
3dSkullStrip : FAILURE
/bin/sh: 3dSkullStrip: command not found : FAILURE
/bin/sh: command not found
3dAllineate : FAILURE
/bin/sh: 3dAllineate: command not found
/bin/sh: 3dRSFC: command not found
SurfMesh : FAILURE
/bin/sh: SurfMesh: command not found
3dClustSim : FAILURE
/bin/sh: 3dClustSim: command not found
/bin/sh: 3dMVM: command not found

none working, testing programs under implied /users/PAS1316/prateeksasan/linux_o penmp_64…
afni : success
suma : success
3dSkullStrip : success : success
3dAllineate : success
3dRSFC : success
SurfMesh : success
3dClustSim : success
3dMVM : success

checking for R packages…
rPkgsInstall -pkgs ALL -check : FAILURE
/bin/sh: rPkgsInstall: command not found

R RHOME : /usr/local/software_usage/R: Permission denied.

checking for $HOME files…
.afnirc : missing
.sumarc : missing
.afni/help/all_progs.COMP : missing

------------------------------ python libs -------------------------------
++ module loaded: PyQt4
module file : /usr/lib64/python2.7/site-packages/PyQt4/init.pyc

** failed to load module matplotlib.pyplot
– matplotlib.pyplot is not required, but is desirable

-------------------------------- env vars --------------------------------
PATH = /usr/local/xalt/xalt/bin:/opt/mvapich2/intel/19.0/2.3.3/bin:/usr/local/gn u/8.4.0/bin:/opt/intel/itac/2019.5.041/bin:/opt/intel/advisor_2019/bin64:/opt/in tel/vtune_amplifier_2019/bin64:/opt/intel/inspector_2019/bin64:/opt/intel/compil ers_and_libraries_2019.5.281/linux/bin/intel64:/usr/local/software_usage:/opt/to rque/bin:/usr/lib64/qt-3.3/bin:/opt/osc/bin:/opt/moab/bin:/usr/local/bin:/usr/bi n:/usr/local/sbin:/usr/sbin:/opt/ibutils/bin:/opt/ddn/ime/bin:/opt/puppetlabs/bi n

LD_LIBRARY_PATH = /opt/mvapich2/intel/19.0/2.3.3/lib:/usr/local/gnu/8.4.0/lib64: /usr/local/gnu/8.4.0/lib:/opt/intel/debugger_2019/libipt/intel64/lib:/opt/intel/ compilers_and_libraries_2019.5.281/linux/compiler/lib/intel64_lin:/opt/intel/com pilers_and_libraries_2019.5.281/linux/daal/lib/intel64_lin:/opt/intel/compilers_ and_libraries_2019.5.281/linux/ipp/lib/intel64_lin:/opt/intel/compilers_and_libr aries_2019.5.281/linux/mkl/lib/intel64_lin:/opt/intel/compilers_and_libraries_20 19.5.281/linux/tbb/lib/intel64_lin/gcc4.4:/opt/torque/lib64:/opt/torque/lib::


------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : did not find TT_N27+tlrc

------------------------------ OS specific -------------------------------
which yum : /usr/bin/yum
yum version : 3.4.3

========================= summary, please fix: =========================

  • just be aware: login shell ‘bash’, but our code examples use ‘tcsh’
  • failure under initial “AFNI and related program tests”
  • AFNI programs show FAILURE
  • consider adding /users/PAS1316/prateeksasan/linux_openmp_64 to your PATH
  • missing R packages (see rPkgsInstall)
  • please run: cp /users/PAS1316/prateeksasan/linux_openmp_64/AFNI.afnirc ~/.afnirc
  • please run: “suma -update_env” for .sumarc
  • please run: apsearch -update_all_afni_help
  • insufficient data for AFNI bootcamp
  • possibly missing atlases

That looks good. Out of the “summary, please fix” items, the main one is:

  • consider adding /users/PAS1316/prateeksasan/linux_openmp_64 to your PATH

So in your .bashrc file, add something like:

export PATH=$PATH:$HOME/linux_openmp_64

Then you can open a new terminal, or just source that .bashrc file.

Note that we have a linux_centos_7_64 package that might be slightly more appropriate for your system, that what you have seems to be working fine.

  • rick

where can i find this?

Sorry, I missed this reply. That .bashrc file should be in your home directory.

Note that in order to see files starting with a ‘.’ character, you should add the -a option to ls.

ls -al
ls -l .bashrc
  • rick