Initializing: X11Error: Can't open display: :0.0 on MacOS 11.6

Hi AFNI devs,

I can no longer open the AFNI GUI on my personal computer running MacOS 11.6 and using the terminal app or even the xQuartz terminal. I do not know if it is related to a software upgrade.

I have tried reinstalling AFNI a couple of times, changing the display settings on my .zshrc file, even following every single response that has been given on this message board related to this topic, and I honestly do not know what else to try. Installing via App did not work either, because apparently my MacOS version is too old.

I would be more than happy to hop on a Zoom call and show you.

How can I make the GUI work again?

Thank you!


Is this an Apple Silicon ARM M1 or an Intel-based CPU? Can you open any X11 application at all? xterm, xclock, xeyes are simple ones that come with XQuartz. You may need to reinstall XQuartz or maybe just restart your computer for the initialization of XQuartz after a new install or update.

Thank you Daniel.

I have an Intel-based MacBook and could open xterm but not AFNI.

Anyway, I have restarted my computer and I can open AFNI from both xterm and the terminal, something I tried many times before but couldn’t make it work. I wonder if xQuartz got updated recently.