GLT error

I am in the process of setting up first level preprocessing for functional activation data. I am trying to to do this. I get the following error when I try to add contrasts including suggested ones from Attached is a screenshot. Any suggestions would be appreciated.

I do not see what is wrong, but it is difficult to read.
There are 2 things you can do to help. One is to
“init with examples” in that “symbolic GLTs” box, then
modify them as you see fit.

Also, you can go under the “Help” menu at the top:
Help->Browse->web:gltsym and stim times

That will give a lot of details and examples.

Or if you could post the labels and GLTs in text, it
would be easier to read (though then we cannot
verify what is in the GUI).

  • rick

I tried the “init with examples” button and got the same error. Could this be an installation error?

Can you get it to generate an command script
and mail it to me? Then I could better see what is going on.
Or if you go to that subject directory and run “ls -al”, just
send me any .orig.* files.

Please mail it to reynoldr .AT.

  • rick

It won’t generate the script. Just gives the error.

I can’t get it to create a script. It just gives me the error message when I try to do so. If I don’t put in any GLTs then I can get a script.

Yes, would you send me that, please?


  • rick

Hi Rick,

Thank you for your assistance. I tried attaching a file and it won’t let me. So, I am putting it in the message portion of this post. Any help you could give would be appreciated.
I have been trying to get another script I recieved from someone else up running, but I keep getting errors when I try to use it. So I thought I might try creating the script using the gui and then put in the rest of the script to see if I could get it working that way. I assume that the errors are connected. It appears that the errors I get from running that script are the result of not being able to find my onsets and anatomy files. But I have checked the addresses and they are correct
Would it be helpful to send that script and the resulting output.proc?

Thank you,

#!/usr/bin/env tcsh

created by version 0.39 (March 21, 2016)

creation date: Mon Apr 3 16:38:45 2017

set data directories

set top_dir = /hosts/feathers/feathers1/fei_data/NIMH_DotProbe/ta9965
set anat_dir = $top_dir/anat
set epi_dir = $top_dir/afni
set stim_dir = $top_dir/onsets

set subject and group identifiers

set subj = ta9965
set group_id = Run1

run to create a single subject processing script -subj_id $subj
-script proc.$subj -scr_overwrite
-blocks tshift align tlrc volreg blur mask scale regress
-copy_anat $anat_dir/ta9965_blumberg_stack3d_S009.nii
-tcat_remove_first_trs 4
-align_opts_aea -cost lpc+ZZ -giant_move
-volreg_align_to first
-blur_size 6.0
AC AI Incorrect N
-regress_basis ‘GAM’
-regress_censor_motion 2.0
-regress_censor_outliers 0.1
-jobs 4
-regress_make_ideal_sum sum_ideal.1D
-regress_run_clustsim no

Hi Linda, would you please mail me these files? I am
not asking you to attach scripts to your posts, but to
send me email with them. My email address was
included in my second message on this thread. That
is a much more reliable way to verify your scripts.

Assuming the analysis has not been run (i.e. there is
no ta9965.results directory), it would be nice if you
just packaged the contents of the entire subj.ta9965
directory, which should contain multiple scripts, and
be very small.

Would you do that please? For example:

cd subject_results/group.Run1
tar cfz subj.ta9965.tgz subj.ta9965

And mail me the subj.ta9965.tgz file.

Also, to be clear, after you “init with examples”, do
you modify them, or just try them as they are?


  • rick

Got it Rick. Thank you. Will do.