Fatal IO error


I’m running AFNI (version 16.3.06) on a Mac with OS X 10.10.5 and I recently upgraded XQUARTZ to version 2.7.11. Unfortunately, when I started AFNI, some of the windows (such as the one indicating there are no data sets in the current directory) are popping up minimized, and when I click the X to close a window, AFNI closes completely and I receive the following error message:

XIO: fatal IO error 35 (Resource temporarily unavailable) on X server “/private/tmp/com.apple.launchd.bmK6GX7Bmn/org.macosforge.xquartz:0”

I’ve already tried uninstalling XQUARTZ and reinstalling version 2.7.10, but that didn’t work. I’ve updated the binaries and most of the software needed to run AFNI listed on the installation page. I’ve also looked through the message board and tried what suggestions I could find but haven’t had any luck thus far.

In addition, when I am able to at least keep the AFNI GUI open and bring up an image, I can no longer use the keyboard to scroll through the image. If anyone has any suggestions, they would be greatly appreciated.


P.S. Here is the output from afni_system_check.py:

-------------------------------- general ---------------------------------
architecture: 64bit
system: Darwin
release: 14.5.0
version: Darwin Kernel Version 14.5.0: Sun Sep 25 22:07:15 PDT 2016; root:xnu-2782.50.9~1/RELEASE_X86_64
distribution: 10.10.5 x86_64
number of CPUs: 4
apparent login shell: bash (current shell is csh)
shell RC file: .cshrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /Users/becbw9/abin/afni
afni version : Precompiled binary macosx_10.7_Intel_64: Oct 31 2016
AFNI_version.txt : AFNI_16.3.06, macosx_10.7_Intel_64, Oct 31 2016
which python : /usr/bin/python
python version : 2.7.10
which R : /usr/bin/R
R version : R version 3.2.3 (2015-12-10) – “Wooden Christmas-Tree”
which tcsh : /bin/tcsh

instances of various programs found in PATH:
afni : 1 (/Users/becbw9/abin/afni)
R : 1 (/Library/Frameworks/R.framework/Versions/3.2/Resources/bin/R)
python : 1 (/usr/bin/python)

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : success
uber_subject.py : success
3dAllineate : success
3dRSFC : success
SurfMesh : success

checking for R packages…
rPkgsInstall -pkgs ALL -check : success

checking for $HOME files…
.afnirc : found
.sumarc : found
.afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
++ module ‘PyQt4’ found at /usr/local/lib/python2.7/site-packages/PyQt4
++ module loaded: PyQt4

-------------------------------- env vars --------------------------------
PATH = /usr/local/bin:/usr/local/bin:/usr/local/bin:/usr/local/bin:/usr/local/bin:/usr/local/bin:/usr/local/bin:/usr/local/bin:/usr/local/bin:/usr/local/fsl/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Users/becbw9/abin:~abin:/Users/becbw9/abin:/Users/becbw9/abin:/Users/becbw9/abin

PYTHONPATH = /usr/local/lib/python2.7/site-packages


------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing suma_demo
data dir : missing FATCAT_DEMO
data dir : missing afni_handouts
atlas : found TT_N27+tlrc under /Users/becbw9/abin

------------------------------ OS specific -------------------------------
which brew : /usr/local/bin/brew
brew version : Homebrew 1.0.9

============================ summary comments ============================

  • login shell ‘bash’, trusting user to translate from ‘tcsh’
  • shell bash: consider sourcing (non-login) .bashrc from (login) .bash_profile
  • insufficient data for AFNI bootcamp

I am also having the same issue…did exactly the same thing and cannot resolve it.

B.M. Ellingson

I was able to make it work again by installing xQuartz version 2.7.9

B.M. Ellingson

Well, I have this problem on my laptop also, and can’t get XQuartz to work with AFNI at all, no matter what version I install. I’m going to update my OS and reinstall everything this weekend – partly because the NIH insists that I upgrade my version of Mac OS X for security reasons.

I rolled back to XQUARTZ 2.7.9 and that resolved my issue as well.


Justin Rajendra reported on the release notes for XQuartz-2.7.10,
noting that there is a backward compatibility solution for builds
against 2.7.9 when running more recent versions of XQuartz, e.g.

setenv DYLD_LIBRARY_PATH /opt/X11/lib/flat_namespace

  • rick

On top of that, Vinai reports that XQuartz 2.7.11 has
become available over the weekend, and it may have
resolved some of these issues (such as windows
getting lost).

  • rick