FAT_MVM no result issue


I am running FAT_MVM to see main effect of group with Functional connectivity(FC) matrix.
Each subject has a 195*195 size FC matrix, and I try to do group analysis with 180 subject.

I have followed FAT_MVM demo and apply this same way to my analysis.

  1. To get data table, I ran

fat_mvm_prep.py -p TEST01 -c all_subj_Cross_Bandpass_3Group.csv
-m ‘Cross_Bandpass_Craddock/*P1_000.netcc’

and it took 12 hours to get data table. I assume that the reason why it took huge amount time only to make the data table is 195 ROIs and 180 subject. Is this right?

  1. Once I get the data table, I ran
    fat_mvm_scripter.py --vars=‘Group Scanner Age Sex Race HAMD YMRS’

and I got TEST01_scri.tcsh. And finally I ran
tcsh TEST01_scri.tcsh

But any result is not provided with the following messages

[b]***** End of data structure information *****

Reading input files now…

Congratulations! The above results are saved in file TEST02_MVM.txt[/b]

There is no result between line “Reading input files now…” and line “Congratulations! The above results are saved in file TEST02_MVM.txt[” and also TEST02_MVM.txt has nothing and file size is zero byte.

Why 3dMVM is not giving any result?


Hi, Jung-

For #1: I believe yes, the size of group and matrices are combining to make a large data table. You can see how many bytes it takes up with “ls -l …” on the file name. 12 hours does surprise me a little bit, though.

For #2: I am not certain. My first thought would be that 3dMVM is running out of memory on your computer, but then there would have been a “killed” message in the terminal, I should think.

To test this out, if you run the fat_mvm* commands with just 5 subjects, say, does that still happen? (Just picking a very small group size, so that we can see whether it is the data, which I doubt, or a memory/size of model issue, which I still suspect.)


Hi Paul,

Thanks for your response.

In my TEST01_scri.tcsh,

3dMVM -prefix TEST01_MVM
-bsVars “Group+Scanner+Age+Sex+Race+HAMD+YMRS”
-wsVars “ROI”
-qVars “Age,HAMD,YMRS”
-dataTable @TEST01_MVMtbl.txt

I have removed ‘glt’ parts to reduce computation cost, but still same empty result has shown.

As your suggestion, I tried to reduce the subject number to just 5 subjects and run it again. But still same empty result.
Also I tried remove covariates as followings,

3dMVM -prefix TEST03_MVM
-bsVars “Group”
-wsVars “ROI”
-dataTable @TEST02_MVMtbl_5Subj.txt

But still it gave me the empty result.

[b]***** End of data structure information *****

Reading input files now…

Congratulations! The above results are saved in file TEST03_MVM.txt[/b]

Finally, I tried to reduce ROI number to only one ROI (ROI_001-ROI_002, ROI_001-ROI_003,…, ROI_001-ROI_200) on every 5 subjects with having covariates back,
But still it is giving empty result.

Is this some kinds of version issue? I tried to do above processing on both python 2.7.16 and 3.7.3.



I’m not sure what would be the problem. Python 2.7 is good.

I’ll send you instructions for uploading the 5 subject (but not just single ROI) case, and take a look.