Exporting ROI from Atlas Problems

Hi AFNI folks,

Please see attached screen grab of my struggles. Trying to export the TE 1.1 area from the CA_22_MPM atlas but for some reason it wont recognize the area name or the area code unlike TE 1.0 and 1.2. Tried dozens of variations. Is there something obvious I am missing here?

Alternative question: Anyone know of an atlas that has a well accepted Primary Auditory Cortex region parceled out, or have a good Mask?

Much appreciated,


Bumping thread

I’m looking into this issue. You can work around this issue in the meantime with 3dcalc to separate left and right using the index or using angle brackets “<Area_TE_1.1>” as the dataset range selector.

3dcalc -a ~/abin/TT_caez_mpm_22+tlrc.‘<Area_TE_1.1>’ -expr ‘step(a)*step(x)’ -prefix TE_1.1_left.nii.gz

Appreciate the help Mr. Glen. Unfortunately I only seem to be able to get the following warnings, even when varying <>, “”, [], area name/code, and X values I only seem to be able to get the following:

  • output sub-brick 0 is all zeros!
  • Symbol x using predefined value
  • can’t open dataset /Users/Credo/abin/TT_caez_mpm_22+tlrc.Area_TE_1.1

I am comfortable splitting the hemispheres after the fact so we can tackle exporting them bilaterally. But afraid I’m a bit stuck.


Hi, Dane-

Can you please copy+paste the exact command you tried? Little things can make a difference (e.g., needing the quotes around the brackets, etc.). Having the full text output copy+pasted, too, will help resolve this.


For the original problem, there was a bug in the way the atlas regions are parsed. It should work in the next binary distribution. Thanks very much for bringing this to my attention.

For the workaround, Paul is correct. Just be careful about putting the angle brackets in quotes.

… and pursuant to Daniel’s fix, we have just started another build of the AFNI codebase now. It should be ready in a couple hours.

You can update your local AFNI version with

@update.afni.binaries -d

and the version number you will be wanting to see from

afni -ver

is: AFNI_21.0.04.


Thank you gents, one and all. Updated binaries and things worked as expected. Much appreciated.