error in fat_proc_convert_dcm_dwis


I have started working through the prepreprocessing fatcat functions on our dti data, and I keep running into the same error running fat_proc_convert_dcm_dwis, and as a result, none of the automatic QC png images are generated. The terminal reads:

My command:
@chauffeur_afni -ulay padcombo.nii -prefix pa_qc_sepscl_3 -olay_off -montx 10 -monty 8 -globalrange SLICE -ulay_range 1% 99% -label_mode 1 -label_size 3 -image_label_ijk
**ERROR: pnmcat pbmtext pamstretch pbmtopgm – not found in path – program fails"

I’m not sure what this means, or how to fix it?

I would appreciate any help!


Hi, Catherine-

I am going to guess you are running on a Mac? If so, to install netpbm, you can follow the instructions here:
using the Homebrew package manager (note that the syntax for those commands is using the bash shell, so if those fail, you can type
“bash”, then copy/paste them, and when done you can type “exit” in the terminal).

If you are on Ubuntu, you should be able to do:

sudo apt-get install netpbm

and be sorted.


Well, I guess I could have just copy+pasted the link contents for installing netpbm on Macs here directly. From the preceding link, it would be copy+pasting the following into your terminal shell (the first and last lines are in case you aren’t running bash):

ruby -e "$(curl -fsSL" < /dev/null 2> /dev/null
brew install netpbm


Thank you very much!

That fixed it I believe!