Error: attempt to add non-widget child "dsm" to parent "1dplot" ...


I am wondering why I got the following error when running 1dplot.

[duongs-mbp:~] dhuynh% 1dplot outcount.r01.1D
++ 1dplot: AFNI version=AFNI_17.0.18 (Mar 29 2017) [64-bit]
++ Authored by: RWC et al.
Warning: Widget must be a VendorShell.
Error: attempt to add non-widget child “dsm” to parent “1dplot” which supports only widgets


If this is on a relative recent Mac OS specifically, the problem may be the one solved by this step from the Mac install instructions:

XQuartz has altered the library format, so adjust DYLD_LIBRARY_PATH by doing either:

tcsh syntax:

touch ~/.cshrc
echo 'setenv DYLD_LIBRARY_PATH /opt/X11/lib/flat_namespace' >> ~/.cshrc

bash syntax:

touch ~/.bashrc
echo 'export DYLD_LIBRARY_PATH=/opt/X11/lib/flat_namespace' >> ~/.bashrc

Dear all, I have the same problem… I’ve already export DYLD_LIBRARY_PATH=/opt/X11/lib/flat_namespace in my .bashrc but I still have the same error (Warning: Widget must be a VendorShell.
Error: attempt to add non-widget child “dsm” to parent “1dplot” which supports only widgets) with afni preprocessing…
Anyone could help me?

Many thanks!

Have you also added this to your .cshrc file too?

I recently installed afni and I am running into the same issue. I have added these commands to both my .bashrc and .cshrc files. However, being a UNIX novice, I am not sure if terminal is running these files at startup since the tab auto completion (e.g. 3dinfo - ) only beeps even though
set filec
set autolist
set nobeep
are also included in this file.

I’m still stuck with tab autocompletion, but for novices after following this advice, in terminal:
cd ~
nano .bash_profile
add the line: “source ~/.bashrc”

this seemed to help my 1dplot error

The tab autocompletion of AFNI programs is a different beast. Run:

apsearch -update_all

and when it is done running (shouldn’t take very long), check the terminal-- there may likely be a message for you to copy+paste something into your current shell’s ~/.*rc file. If not, just open a new terminal, and put an AFNI command followed by a space and a hyphen ‘-’, and then hit tab (probably a few times, since you will have several options to complete). Does that work?

Re. the beeping-- are you on a Mac? To turn that annoyance off, go to the Terminal’s menu bar, select Terminal → Preferences → Profiles → Advanced, and then deselect “Audible bell” and “Visual bell” items.

On Ubuntu, at least, I don’t think there are bells by default.

Note that the “set file …” and other “set …” commands are only for your ~/.cshrc file, not for ~/.bashrc (as noted in the instructions here: The syntax is wrong for ~/.bashrc-- that might even cause an error when reading the ~/.bashrc file, so you should remove those from it.

To find out what shell you are using in a terminal, you can type:

echo $0