Dimon and to3d epi dataset import error as single volume

AFNI version info (afni -ver): Version AFNI_21.0.04 'Titus'

Dear AFNI experts,

I am a relatively new AFNI user and I was hoping you could assist me with a question.

I am having issues importing an EPI dataset from a Bruker scanner using Dimon and to3d. I successfully imported data from other Bruker scanners with similar commands I am trying now.
This is a single 10 min long EPI resting-state scan of a mouse brain. I saved the data both in dicom (for Dimon import) and the original 2dseq file (which I tried with to3d).
I should also clarify that my dicom file was saved as a single dicom file (and not multiple dicom files).

The problem I am having is that the scan is being taken a single volume (single TR) with 14400 slices, instead of 300 volumes with 48 slices each.
These are the details of my scan:

Matrix: 144x80, 48 slices
Resolution: (0.1 x 0.1)mm, 0.2mm slice thickness
FOV: (14.4 x 8)mm in XY-plane, 9.6mm in Z-axis
TR = 2 second, two-shot EPI (two sequential segments)
 Number of TRs: 300, length of scan 10 mins

I tried importing the dicom file with the following (and other similar parameter combinations):

Dimon -infile_prefix datascan.dcm -sp alt+z -tr 2.0 \
   -num_slices 48 -nt 300 -dicom_org \
   -gert_create_dataset -use_obl_origin

This is an example of Dimon output that I get:

Dimon version 4.26 (February 3, 2020) running, use <ctrl-c> to quit...

-- scanning for first volume
++ Data detected to be oblique
** CID: have non-mosaic datascan.dcm with 14400 images
.*+ WARNING: Image Positions do not lie in same direction as cross product vector: 0.505359

-- first volume found (1 slices)
-- scanning for additional volumes...
-- run 60001: 1 

final run statistics:
    volume info     :
        slices      : 1
        z_first     : -4.421
        z_last      : -4.421
        z_delta     : 0.2
        oblique     : yes
        mos_nslices : 0 

    run #60001 : volumes =   1, first file (#0) = datascan.dcm

++ writing dimon file list to dimon.files.run.60001
++ oblique data: applying to3d -oblique_origin
set OutlierCheck = 
set OutPrefix = OutBrick
to3d -prefix OutBrick_run_60001 -oblique_origin -@
++ to3d: AFNI version=AFNI_21.0.04 (Jan 18 2021) [64-bit]
++ Authored by: RW Cox
++ It is best to use to3d via the Dimon program.
++ Counting images:  total=14400 2D slices
++ DICOM WARNING: file datascan.dcm has Rescale tags
   setenv AFNI_DICOM_RESCALE YES to enforce them
++ Data detected to be oblique
++ Each 2D slice is 144 X 80 pixels
++ Voxel dimensions: 0.1000 X 0.1000 X 0.2000 mm
++ Image data type = short
++ Reading images: ..........................................
*+ WARNING: Image Positions do not lie in same direction as cross product vector: 0.505359
++ 3D dataset written to disk

I also tried directly importing the 2dseq file with this:

to3d -epan -prefix data_r06 xFOV 7.2L-R -yFOV 4S-I -zSLAB 4.8P-A \
-time:zt 48 300 2000 alt+z 3D:0:0:144:80:14400:2dseq

Same as before, the file keeps being imported a single volume with 14400 slices.

Do you have any suggestion for how to properly import this data?

Thank you very much in advance for your help.


If this is an entire 4-D run in a single DICOM file, then it is probably the newer format that Dimon cannot read. Dimon can handle slices or Siemens mosaic volumes, but not the 4-D version. You could go with dcm2niix (or dcm2niix_afni as we distribute it) in this case, unless you can get the other format.

Sorry about that,

  • rick

Hi Rick,

Thank you very much for your answer.
Using dcm2niix_afni, I could convert my single 4-D dicom file to Nifti format.

I opened this new Nifti file with AFNI and it seems to have been correctly interpreted as 300 volumes with 48 slices each as intended. The TR was off (as well as orientation as expected) but I could correct that with 3drefit.

I think this Bruker scanner had Paravision 6 until recently and I could import Dicom or 2dseq files. But they have recently upgraded it to Paravision 360 (newer version) which seems to save one single 4D Dicom file. I am not sure why I couldn't import the 2dseq directly though.