can't see all sub-briks in 3dMVM output

Hi all,

Sorry to post this topic given that it’s been answered before, but the previous solutions haven’t worked for me. I have 150 sub-briks or so in my overlay file, but I can only see 99 sub-briks in the sub-brik selector dropdown menu. When I expand the browser to full size, I can see a bit more but not the full number of sub-briks. I’ve tried right-clicking next to the OLAY button on the left of the sub-brik selector, but nothing happens. I’ve tried changing AFNI_DISP_SCROLLBARS to yes, AFNI_MAX_OPTMENU to 300 (although that doesn’t make much sense), and other settings but nothing changes. Can someone point out how to adjust this so that I can view my full results?


Hmm, that’s odd. I just tested with an EPI time series on my laptop Linux-ubuntu-16, with ‘afni -ver’:

Precompiled binary linux_ubuntu_12_64: Feb  5 2019 (Version AFNI_19.0.07 'Tiberius')

I had an EPI time series with 242 time points, and could select them all either with right-clicking on the Olay button (see attached image) or with leftclicking on the actual menu (that opened up a multicolumn selector panel).

What is your “afni -ver”?


Thanks so much for your quick response! I’m using precompiled binary linux openmp 64: Nov 19 2018 (Version AFNI 18.3.05). I’m able to right click other menus in the GUI, but for some reason when I right click the Olay button next to the sub-brik selector, nothing happens. I’m not sure if it’s a noVNC or AFNI issue. Even so, when I left click, I don’t have a scroll bar like you do (see image attached). Am I missing a setting in my .afnirc file that I should include to enable that?


Hi, Laura-

Ah, based on your “noVNC” remark, is this happening when you are remotely logged in to another machine? That doesn’t immediately suggest a solution to me, but that is interesting; what kind of system are you logging in from?

Presumably, you do get a normal AFNI selector/scrollbar menu if you hit the “Overlay” or “Underlay” button (which you would use to select an overlay or underlay to start with?

Normally, when you left click on the name of the subbrick, you get the large menu like you have (though, I guess it is so large that it is truncated for you?).

The way I got the scrollbar menu was by right-clicking on the ‘Olay’ button itself (not on the name of the subbrick immediately to its right).

Just to clarify, that isn’t working (right-clicking on the word ‘Olay’ there)?


Hi Paul,

I’m logging in from my mac to the NCF computer cluster. Right-clicking on the Olay button to the left of the sub-brik selector doesn’t do anything, but I can right-click on other locations (e.g., if I right-click the Olay button above the Clusterize button, a menu pops up). This is the case whether I use noVNC to log in or XQuartz. Left-clicking provides the large menu that I screenshotted in the previous message, but it’s truncated, so I can’t see all of my results. I get a normal scrollbar menu when left-clicking the Overlay or Underlay button. Is there another way to get a scrollbar menu for the sub-brik selector?


Hi, Laura-

Wow, that is confusing, since the other menus open up fine. I am remotely logged into to a cluster here at NIH (“ssh -X …”), and I can open the menus fine, including the Olay one.

Some thoughts:

  • The only time me rightclicking on Olay did nothing was if the volume had only 1 subbrick. In your case, I don’t see how this would be a problem, though, because you have 150 subbricks.
  • Is it possible that the menu is opening up off screen (for what is being sent back to your Mac)? I wonder if that is an issue, because of how the large menu is being truncated.
  • I wasn’t sure whether you mentioned trying opening AFNI on your Mac directly and if the same behavior applies (or if you had just ssh’ed from your Mac, without using noVNC). If you do try just opening a multibrick overlay on your Mac, does this happen? And what is the output of “ -check_all” on your Mac?
  • I can also “shift+rightclick” on Olay and get the scrollbar menu-- does that work?
  • Finally, in the lefthand part of AFNI GUI is an “index” button-- you could type in the index that you want and hit Enter, and the olay should jump to that. If your ulay has only one brick, it will just stay there; the question of what happens with your Thr brick index depends on what you have set on your computer. You can set it to jump to that same index, or to jump to the Olay index+1, or to be “free” and independent-- that can be done through ~/.afnirc options (see below), or by the dreaded right-click on the “Index” button itself.


about relevant environment variables from here:

Variable: AFNI_SLAVE_FUNCTIME (editable)
When the underlay and overlay datasets both are time-dependent,
switching the time index will change both the underlay and overlay
sub-bricks. If you want the time index control to change ONLY the
underlay sub-brick, then set this variable to NO.

This variable allows you to control the INITIAL setting of the widgets
that slave (or not) the threshold index to the overlay index. (These
widgets are on the 'Index' right-click popup chooser and on the
threshold slider right-click popup menu.)  The values you can set for
this variable, and their effects, are listed below (not case
  'OLay'    *or*  '=='  *or*  '0'  ==> threshold index = overlay index
  'OLay+1'  *or*  '+1'  *or*  '1'  ==> threshold index = overlay index + 1
  ANYTHING ELSE                    ==> threshold index is free and wild
This variable replaces the 2 variables listed below. Again, this only
controls the INITIAL setting of the widgets -- you can change them in
the AFNI GUI later at any time. Setting this variable after AFNI
starts (e.g., from plugout_drive) will have little discernable effect.

Great! Thanks. Shift + right-click worked.


Hi, Laura-

Wow, I was really reaching at straws there! Glad that one worked.