Cannot enter values into gui when viewing results

I am unable to enter values using the afni gui when viewing my results. Buttons/sliders work (i.e., I can change the NN level under “clusterize” using the up and down arrows; I can change the p-values using the slider tool) but I cannot type in values (i.e., I cannot type in the NN level or voxel number under “clusterize” or the p-value); I see a cursor in the entry box but I cannot type in number (screenshot attached).

As a side note, I can hold down the slider and use the up/down keys to change the p-value if needed (screenshot attached), but I was wondering if there is a way to more precisely specify the p-values.

AFNI and Mac versions:
Precompiled binary macosx_10.7_local: May 26 2017 (Version AFNI_17.1.07)
Mac OS X El Capitan version 10.11.6

This is probably due to changes in X11. If you look at this page and specifically the part about flat_namespace, which depends partially on which shell you’re using (bash vs. tcsh):

echo 'export DYLD_LIBRARY_PATH=/opt/X11/lib/flat_namespace' >> ~/.bashrc

If that doesn’t work, please provide us the output of: -check_all

It worked! Thank you! I have shared this with our lab, since several people were having this issue. Have a great day!

hi Kathryn

Just to give you a quick answer to your side question–yes, if you right click on the displayed p value below the slider a menu comes up, one of whose options is to set the p-value.


That’s right, and it’s also available by right-clicking on the text (“T-t”) just above the threshold slider. Occasionally, these will have slightly different behavior depending on the operating system. And in case, this is a repetitive situtation, consider scripting this with a plugout script with this plugout_drive option:

SET_THRESHNEW [c] val [flags]
Sets the threshold slider for controller index ‘c’ (default=‘A’) to the
numerical value ‘val’, which must be in the range [0…9999]. If the
optional ‘flags’ string contains the character ‘*’, then the slider decimal
offset (i.e., the ‘**’ setting) will be changed to match the size of ‘val’.
If ‘flags’ contains the character ‘p’, then 'val will be interepreted as
a p-value (and so must be between 0.0 and 1.0). Examples:

Thank you, James and Daniel. I had been using the slider, since manually changing the p-value was not working for me. I was hoping to manually type in the p-values for enhanced precision. Peter’s fix worked- my issues were related to X-11.

Thank you for this code, Daniel!

Hi Peter,
I am sorry to bother you again. I noticed that while I can now change the p value, when I select bi-sided? “yes” and select “apply” and “set” it keeps bi-sided set to “no”. I have closed and reopened AFNI but this error persists.

I ran the afni system check, with the output provided below:

psy-bdl-macpro-dsn:3dMVM_noresiduals kathrynj$ -check_all
-------------------------------- general ---------------------------------
architecture: 64bit
system: Darwin
release: 15.6.0
version: Darwin Kernel Version 15.6.0: Wed Nov 2 20:30:56 PDT 2016; root:xnu-3248.
distribution: 10.11.6 x86_64
number of CPUs: 8
apparent login shell: bash
shell RC file: .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /Users/kathrynj/abin/afni
afni version : Precompiled binary macosx_10.7_local: May 26 2017
: AFNI_17.1.07
AFNI_version.txt : AFNI_17.1.07, macosx_10.7_local, May 26 2017
which python : /usr/bin/python
python version : 2.7.10
which R : /usr/local/bin/R
R version : R version 3.3.3 (2017-03-06) – “Another Canoe”
which tcsh : /bin/tcsh

instances of various programs found in PATH:
afni : 1 (/Users/kathrynj/abin/afni)
R : 1 (/Library/Frameworks/R.framework/Versions/3.3/Resources/bin/R)
python : 1 (/usr/bin/python)
python2 : 0
python3 : 0

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : success : success
3dAllineate : success
3dRSFC : success
SurfMesh : success

checking for R packages…
rPkgsInstall -pkgs ALL -check : success

checking for $HOME files…
.afnirc : missing
.sumarc : missing
.afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** python module not found: PyQt4

-------------------------------- env vars --------------------------------
PATH = /usr/local/fsl/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Library/TeX/texbin:/Users/kathrynj/abin:/Users/kathrynj/abin

DYLD_LIBRARY_PATH (sub-shell) =

------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : found TT_N27+tlrc under /Users/kathrynj/abin

------------------------------ OS specific -------------------------------
which brew : /usr/local/bin/brew
brew version : Homebrew 1.1.11

++ found 1 dylib files under ‘/opt/X11/lib/flat_namespace’
– found ‘libXt’ dylib files:
– recent OS X, cannot check DYLD_LIBRARY_PATH in cur shell, cheating …
** env var DYLD_LIBRARY_PATH not set to contain /opt/X11/lib/flat_namespace
– recent OS X, cannot check DYLD_LIBRARY_PATH in shell ‘tcsh’, cheating …
** env var DYLD_LIBRARY_PATH not set to contain /opt/X11/lib/flat_namespace

========================= summary, please fix: =========================

  • login shell ‘bash’, trusting user to translate from ‘tcsh’
  • shell bash: MISSING login setup file, e.g. .bash_profile
  • shell bash: consider sourcing (non-login) .bashrc from (login) .bash_profile
  • consider running: cp /Users/kathrynj/abin/AFNI.afnirc ~/.afnirc
  • consider running “suma -update_env” for .sumarc
  • insufficient data for AFNI bootcamp
  • note: pyqt4 is no longer available via brew
  • consider installing gcc under homebrew
  • consider installing glib under homebrew
  • please set DYLD_LIBRARY_PATH to /opt/X11/lib/flat_namespace in bash
  • please set DYLD_LIBRARY_PATH to /opt/X11/lib/flat_namespace in tcsh

That does not seem like it is showing the current
parameter, but rather the default value for a new
clusterization operation.

Setting Bi-sided to Yes in the Clusterize plugin
does have that effect. But when clicking on
Clusterize again, it still shows “No”, because
that refers to the next clustering that you are
about to do, but haven’t yet done.

  • rick

Hi Rick,
Thank you very much for your prompt reply.

To clarify, in the past, prior to changing my library path, when I selected bi-sided, I could change it to say “yes”, then apply and set that value. If I were to immediately open up clusterize button again, before selecting a new contrast, it would show my currently selected values: NN=3, k=30, bi-sided=yes.

Now, when I do this, it will still show the new NN and k values of NN=3 and k=30, but bi-sided will be set to “no”.

Running past versions of (up to 2 years) afni rings a better bell for me.
I do not think there has been a change, but that NN and k are always
retained, while bi-sided is not.

So it is fair to ask about that, but I don’t think it has changed.

  • rick