Another casualty in the M1 installation saga

I'm getting some issues similar to others who have posted when attempting to install AFNI on a Mac with an M1 chip running OS Sonoma.

Here are some basic deets:

  • I'm using the process presented at: 1.1.8. macOS 12+ (Apple Silicon/ARM processor/chip: M1, M2, …) — AFNI, SUMA and FATCAT: v24.1.11

  • The first apparent indication that something is amiss is when running OS_notes.macos_12_b_user.tcsh. It gets somewhere just past the line rPkgsInstall -pkgs ALL |& tee out.rPkgsInstall.txt and then says "setenv: Too many arguments." This is quite late in the install process, though, and the install failure is less than subtle so it seems reasonable that the issue occurs upstream and only becomes apparent here.

  • Per your recommendations in similar threads, I checked on all the various home-brew packages and the following are installed and up-do-date: libpng jpeg expat freetype fontconfig openmotif libomp gsl glib pkg-config gcc libiconv autoconf libxt mesa mesa-glu libxpm

Here are some more detailed deets--output from running -check_all:

-------------------------------- general ---------------------------------
architecture: 64bit
cpu type: arm
system: Darwin
release: 23.4.0
version: Darwin Kernel Version 23.4.0: Fri Mar 15 00:10:42 PDT 2024; root:xnu-10063.101.17~1/RELEASE_ARM64_T6000
distribution: 14.4.1
number of CPUs: 10
apparent login shell: zsh
shell RC file: .zshrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni :
AFNI_version.txt : AFNI_24.1.11, anyos_text, May 10 2024, local
which python : /opt/homebrew/opt/python/libexec/bin/python
python version : 3.12.3
which R : /usr/local/bin/R
R version : R version 4.3.1 (aarch64-apple-darwin20)

instances of various programs found in PATH:
afni : 0
R : 1 (/Library/Frameworks/R.framework/Versions/4.3-arm64/Resources/bin/R)
python : 1 (/opt/homebrew/Cellar/python@3.12/3.12.3/Frameworks/Python.framework/Versions/3.12/bin/python3.12)
python2 : 0
python3 : 2

** have python3 but not python2

testing ability to start various programs...
afni : FAILURE
/bin/sh: afni: command not found
suma : FAILURE
/bin/sh: suma: command not found
3dSkullStrip : FAILURE
/bin/sh: 3dSkullStrip: command not found
3dAllineate : FAILURE
/bin/sh: 3dAllineate: command not found
/bin/sh: 3dRSFC: command not found
SurfMesh : FAILURE
/bin/sh: SurfMesh: command not found
3dClustSim : FAILURE
/bin/sh: 3dClustSim: command not found : success
setenv: Too many arguments.

------------------------ dependent program tests -------------------------
checking for dependent programs...

which tcsh : /bin/tcsh
tcsh version : 6.21.00
which Xvfb : /opt/X11/bin/Xvfb

checking for R packages...
rPkgsInstall -pkgs ALL -check : FAILURE
setenv: Too many arguments.

R RHOME : /Library/Frameworks/R.framework/Resources

------------------------------ python libs -------------------------------

++ module loaded: matplotlib.pyplot
module file : /opt/homebrew/Cellar/python-matplotlib/3.8.4/libexec/lib/python3.12/site-packages/matplotlib/
matplotlib version : 3.8.4

** failed to load module flask
-- flask is not required, but is desirable

** failed to load module flask_cors
-- flask_cors is not required, but is desirable

-------------------------------- env vars --------------------------------
PATH = /opt/homebrew/bin:/opt/homebrew/sbin:/usr/local/bin:/System/Cryptexes/App/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/var/run/

R_LIBS = /Users/paulhamilton/sw/R-4.4.0
DYLD_LIBRARY_PATH (sub-shell) = :/opt/X11/lib/flat_namespace

----------------------------- eval dot files -----------------------------

----------- AFNI $HOME files -----------

.afnirc                   : found
.sumarc                   : missing
.afni/help/all_progs.COMP : found

--------- shell startup files ----------

-- good: .tcshrc seems to contain 'source .cshrc'
-- considered operations: path, apsearch

-- note: followers should not need edits, so edit flags should be 0
(have 1 follower(s), which can be ignored)

no modifications needed across 3 dot files

------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : did not find TT_N27+tlrc

------------------------------ OS specific -------------------------------
XQuartz version : 2.8.5

which brew : /opt/homebrew/bin/brew
brew version : Homebrew 4.3.0

========================= summary, please fix: =========================

  • just be aware: login shell 'zsh', but our code examples use 'tcsh'
  • missing program: afni
  • failure under initial "AFNI and related program tests"
  • AFNI programs show FAILURE
  • missing R packages (see rPkgsInstall)
  • please run: "suma -update_env" for .sumarc
  • insufficient data for AFNI bootcamp
    (see "Prepare for Bootcamp" on install pages)
  • possibly missing atlases
  • consider installing gcc under homebrew
  • consider installing glib under homebrew

Little (lotta?) help?


It looks like gcc versions may have changed. The advice below worked for another.

@dglen--Jinx! Just tried this fix based on your advice to another user and it worked just right. I should have figured that there was a compiler issue. Before, all the source code was in AFNI_build but no binaries were getting generated. Thanks for figuring this out!

1 Like