Analysis using afni but no REML

Hello, I have set up an analysis using, but I would like to use only simple linear regression, not random effects. This is partly for time and space considerations, but also because I would like to compare my results to results from another package that does not have a random effects method. I understand that I could do ONLY the REMLfit by using the -x1D_stop option, but I want to do the opposite. Also, since the command and matrix for 3DREMLfit will be produced, I can go back and do the RE analysis later (which I may elect to do, but at this time do not want to). How can I do this? Do I just omit “-regress_reml_exec”?

Thank you,

Here is my -subj_id ${subj}
-copy_anat ${subj}_structural+orig
-dsets 00005+orig 00006+orig 00007+orig 00008+orig 00009+orig 00010+orig
-blocks despike tshift align tlrc volreg blur mask
scale regress
-tcat_remove_first_trs 5
-align_opts_aea -cost lpc+ZZ
-volreg_align_to MIN_OUTLIER
-mask_epi_anat yes
-regress_stim_labels farff nearff meDFf
-regress_basis ‘BLOCK(6,1)’
-regress_censor_motion .3
-gltsym ‘SYM: +nearff +nearfl +nearll -farff -farfl -farll’
-glt_label 1 all_near_far
-gltsym ‘SYM: +nearff -farff’
-glt_label 1 FF_near_far
-gltsym ‘SYM: + +nearll -farll’
-glt_label 1 LL_near_far
-gltsym ‘SYM: +nearfl -farfl’
-glt_label 1 FL_near_far


Actually, it looks like you have already run 3dDeconvolve (and 3dREMLfit). What stats files do you have?

ls stats*

Yes, if -regress_reml_exec is removed, then 3dREMLfit will not be run.

Does it look like you already have the 3dDeconvolve output?

  • rick

Hi Rick,

What do you mean it looks like I have already run 3dDeconvolve?

I have both stats.{subj}+tlrc files and stats.{subj}_REML+tlrc and _REMLvar, so actually 3 kinds of stats files (after running the proc.{subj} ).

I removed the -regress_reml_exec option, but it looks like that did not prevent REMLfit from running.


Hi Priya,

That stats.$subj+tlrc dataset should be from 3dDeconvolve, while the _REML version is from 3dREMLfit, so it does look like you already have those results.

If the -regress_reml_exec option is removed, that program should not be run. However, 3dDeconvolve still says how to run it, showing a sample command. Though without that option, I expect there is no stats*_REML dataset, because the command was not actually run.

  • rick

Hi Rick and Priya-

I seem to be experiencing the same thing. I have nothing in my AP script about reml stuff, and even have “-regress_run_clustsim no” added to speed things up. My resulting proc.* script also has nothing in it about REML at all, and yet in the output it looks like 3dREMLfit is being run after 3dD because the “voxel loop” part takes upwards of 10 minutes to cycle through its counting. This is annoying when i’m trying to do rapid turn-around of mutiple AP runs and, like Priya, just want a simple linear regression for the time being. Am I missing something? let me know if i should send any code or outputs, thanks!


Hi Sam,

Would you send me the proc script via email?


  • rick