not using the correct input

AFNI version info (afni -ver): 23.1.02


I ran the script to do the preprocessing on my sample. After running it, we wanted to re-run the regress block only with a different censoring threshold and see how it effected the number of participants in the sample. I used -dsets to specify that I wanted to run the regress block on the pb04.$sub_id.r01.scale+tlrc image. However, when I look at the output of the new regression block (i.e. the errts file), it says that the input that went into 3dDeconvolve was the pb00.$sub_id.r01.tcat image instead. How do I specify the correct input?

Here is my command:

cd $resultsdir -subj_id $sub_id \
    -dsets $resultsdir/pb04.$sub_id.r01.scale+tlrc \
    -out_dir $resultsdir/regress_higher_thres \
    -blocks regress \
    -regress_apply_mask \
    -regress_motion_file $startdir/$sub_id.results/dfile_rall.1D \
    -regress_stim_types AM1 \
    -regress_basis 'dmBLOCK' \
    -regress_stim_times $stim/* \
    -regress_stim_labels con2 con1 low high1 high2 motor \
    -regress_local_times \
    -regress_opts_3dD \
        -gltsym 'SYM: +low -high1' \
        -glt_label 1 low_vs_high1 \
        -allzero_OK \
        -GOFORIT 6 \
        -jobs $cpu_num \
    -regress_motion_per_run \
    -regress_censor_motion 0.3 \
    -regress_censor_outliers 0.05 \
    -regress_3dD_stop \
    -regress_reml_exec \
    -regress_compute_fitts \
    -regress_make_ideal_sum sum_ideal.1D \
    -regress_run_clustsim no \
    -html_review_style pythonic \

The resulting proc script always names the copied original EPI data as pb00. You are running a new proc script with new input and output, even if it is just for one block (regress). The script always starts at pb00 for the first prefix (tcat), but then you go straight into the regression.

I would expect your command to be okay (at a glance), except for the -regress_apply_mask option, as there does not appear to be any known mask in this command. Maybe you would want a -mask_import option.

On the other hand, we basically never suggest masking at this stage (unless you have done a blur_in_mask or similar).

  • rick

Ahhh okay that makes sense! Sounds good. I will also adjust the argument with the mask. Thanks so much for your help!

The reason I was worried about it was because when I looked at the APQC report for the new regression, there was an EPI variance lines warning that wasn't there in the initial APQC report when I ran the whole preprocessing script at a different censoring threshold - and the image that it showed slices from looked very different from the one shown in the first APQC report. Is that just a feature of the EPI variance warning looking at an earlier (un-preprocessed) version of the EPI in the original script, and since we are using the preprocessed one in our 2nd, regression only script, the warning comes up?



Hi Ryann,

Oh, that is an interesting aspect. The variance lines are meant to be checked on non-registered data, and might be misleading when using the scaled input (though now I am curious what you are seeing). Maybe I should disable that if there is no volreg block, for instance. I will ponder...


  • rick

So in the original APQC, from the afni_proc script that did all the preprocessing blocks, I get no EPI variance line warning, but on the APQC report for the 2nd script that only does the regress block, this is what I get (I have gotten a similar warning on all the other subjects I have re-run through the 2nd script so far):

Oh indeed, it is complaining about scaled variance outside the brain. Yes, I will block that.