AFNI, WSL 1, and CiscoVPN


this is not really an AFNI question but it is related to using AFNI so I hope it’s still OK to post.

I am encountering a weird problem while using AFNI on an NIH-owned Windows laptop, working from home.

AFNI is installed on Ubuntu 18.04 which runs on WSL 1.

As an NIH employee, every now and then I have to VPN to NIH network to do various things that are not accessible from the outside. I am using CiscoVPN as provided by the NIH.

The issue is that connecting to VPN usually (though, curiously, not always) leads to crash of WSL which kills Ubuntu and whatever was open in Ubuntu, including AFNI.

I traced the cause to Windows service LxssManager being stopped, presumably by CiscoVPN. I can restart the service using “sc config LxssManager start=auto” with admin privileges, and the restart Ubuntu & AFNI. But still it is annoying to remember not to connect to VPN while there is an analysis running, or while I have AFNI GUI up with many carefully arranged windows, because I have to start over.

I tried to get help from NIH IT, and I got pretty far including someone in the VPN team looking at my CiscoVPN logs, but they just said they see nothing related to LxssManager.

So, I am wondering of anyone has encountered this issue too, and maybe found a good workaround - better than carefully timing VPN sessions around AFNI work.

WSL 1 and 2 do networking differently, so you might have better luck switching to the other. CIT hasn’t yet supported WSL 2, I think. Also. I saw these posts regarding VPNs and WSL that might help. Another choice is to keep the VPN on all the time.

Thank you. I am sticking to WSL 1 for two reasons: first, as you said, CIT keeps us on a version of Windows that does not run WSL 2. Second, it seems that getting AFNI GUI to work on WSL 2 is over complicated… I tried it on a non-gov machine with WSL 2, ran into problems, got some suggestions from you (,159772,165003#msg-165003) but they were pretty complicated for me and you also said " you can also consider switching to wsl version 1, where the X11 configuration was simpler" so I took that easy way :slight_smile:

Thank you for the links, I’ll keep digging. I’ve been trying to keep VPN on, which helps most of the time - except overnight. I guess something happens that forces VPN to re-establish connection. The laptop is set not to go go to sleep when on AC, but seems to be something else going on,