adwarp.c error

Hi all,

I am trying to use the adwarp -apar to created talairached HEAD and BRIK files with specific contrasts. When I type in

adwarp –apar 3dvol+tlrc –dpar C+orig (C being the specific contrast, which I created a file for already)

I get the following message:

adwarp.c Error: Cannot read anat parent dataset.

Please advise


Hi, Nicole-

Hmm, I ran the following and it worked for me:

adwarp -apar FIRST_DSET+tlrc -dpar OTHER_DSET+orig -prefix OUTPUT_NAME

… so I’m not immediately sure. What is the output of

afni -ver

for you?

One possible thing to note from what is copied+pasted: those hyphens in the option names don’t look like real, ASCII hyphens; I would try deleting those characters, and retyping them (this kind of badness occurs when copy+pasting from PDFs, which usually contains weird characters).

On a larger note, though, I wonder about possibly having a more modern program to perform this process… Are you purely resampling the “-dpar …” dataset to be on the grid of the “-apar …” dataset (so, only a resampling of the grids/space names), or are you trying to warp/align/move the brain the “-dpar …” dataset to align better with the “-apar …” one? Or are you doing something different with this?


If you are doing nonlinear alignment as part of your alignment pipeline, then you probably don’t want to use adwarp. That only does affine and 12-piece transformations. Instead you would supply the affine and nonlinear warp transformations to 3dNwarpApply.

Hi Nicole,

It seems likely that you are just not specifying the correct file name, such as with a leading directory or something.

Make sure that “ls -l 3dvol+tlrc*” works, for example.

  • rick

The output I get is the following:

(Version AFNI_19.2.24 ‘Claudius’)

I’ve tried deleting and retyping the symbols, but unfortunately that hasn’t helped.


Hi Rick,

“ls -l 3dvol+tlrc*” did not work for this dataset, what does that indicate?


Hi Nicole,

That means the name of the file is not correct. Just type ‘ls’ in that directory, do you see it? Or perhaps it is in a different directory.

I must wonder though, have you considered using for the single subject analysis? What steps are you current using to do single subject analysis?

  • rick