Adding an atlas available for -Whereami queries


I have a volumetric dataset made up of labeled regions within the rat brain (I’ve attached a picture here) and I am attempting to turn it into an afni atlas that I can access using the where am i tool in the GUI. I’ve tried using @atlasize and haven’t been able to make available to use in the whereami tool. Here’s my code:

-dset ROIs.nii
-lab_file ROIs_list.txt 1 0
-atlas_type G
-atlas_name Rat
-atlas_description ‘Rat_Atlas’

Where I run it, it appears to work. I get this message “Putting copy of atlas in /home/scarlatamj/CustomAtlases”.

But then my whereami option is still inactive.

And here is a fragment of my ROI_list textfile so you can see what it looks like. I’m worried that the format of the list is the issue.

88 PIL
79 PAG
10 AIV
4 PrL
20 S1FL
89 RNC
11 Claustrum
5 M1
6 M2
21 S1DZ
30 S1BF
12 Peduncle
13 S1J
7 Cg1
22 S1DZO
31 AIP
40 Re, VRe
41 VH
14 CPu
8 IL
23 S1UpL
32 fimbria, fornix
42 PH
15 GI

Anything jumping out at you as something I’ve done wrong?



Your CustomAtlases.niml file should contain the definition for your Rat space. That’s a simple text description as in AFNI_atlas_spaces.niml in your abin directory. You should also set the AFNI environment variable AFNI_SUPP_ATLAS_DIR to point to the directory where you have the atlas and the CustomAtlases.niml file. Finally, make sure your datasets are marked as being in the “Rat” template space you just defined. Template spaces will be inherited automatically with AFNI alignment tools, but you can do this manually with 3drefit -space “Rat” mydset.nii.

Thank you for your response! Unfortunately I’m still having issues. My CustomAtlases.niml file has my rat space and I set the AFNI environment variable AFNI_SUPP_ATLAS_DIR to the right place but my atlas apparently doesn’t contain anything. When I run the command “whereami -show_atlas_code | less” I get this happening for the atlas I made.

Atlas Rat, 0 regions
----------- Begin regions for Rat atlas-----------
----------- End regions for Rat atlas --------------

Any ideas for what’s going wrong?

You have to populate the labels in the header of the atlas dataset. The program @Atlasize does this. Check the output has the correct with “3dinfo -atlas_points myatlas.nii”. Avoid punctuation and symbols in the names of the region; two of the labels have commas and spaces in them, and that might cause problems.

If you would like, you may send me the datasets and a text files with labels and corresponding indices, and I’ll help configure this for you. Other users will then be able to take advantage of our work. There is an atlas available for the rat described here:,149239,149239

Getting rid of the commas and spaces worked!! Thank you so much for your help!!