3dvolreg Choleski

** ERROR: Choleski factorization failure in startup_lsqfit [0]
** ERROR: mri_startup_lsqfit: bad call to startup_lsqfit!
Hello, I am trying to motion correct an fMRI data set and I am encountering the following error. This is a script that we have been using in lab on data acquired with the same protocol. Any suggestions would be appreciated.

I have tried to change all parameter and the functions to perform the alignment (Fourier, linear, cubic, heptic, etc) and its all failing with the same error.

Fatal Signal 11 (SIGSEGV) received
3dvolreg main
Bottom of Debug Stack
** Command line was:
3dvolreg -twopass -twodup -verbose -rot_thresh 0.1 -dfile funcmotion -1Dmatrix_save motionpar.1D -base ‘4Dvolume0001_afni+orig[0]’ -tshift 0 -prefix volreg ‘4Dvolume0001_afni+orig[0…209]’
** AFNI version = AFNI_17.0.02 Compile date = Jan 20 2017
** [[Precompiled binary macosx_10.7_Intel_64: Jan 20 2017]]
** Program Death **
** If you report this crash to the AFNI message board,
** please copy the error messages EXACTLY, and give
** the command line you used to run the program, and
** any other information needed to repeat the problem.
** You may later be asked to upload data to help debug.

I believe in the past this kind of error was seen with odd datasets - maybe TRs that were all zero, for instance. Check over that particular dataset for issues.

Thank you Daniel! I have tried it in all data sets and I get the same error. My boss ran the same dataset, same command on his computer and it worked fine. He used a linux virtual machine and I have a mac. However, he created the script (with this command) on a mac. I have tried running the problematic command

3dvolreg -twopass -twodup -verbose -rot_thresh 0.1 -dfile funcmotion -1Dmatrix_save motionpar.1D -base 4Dvolume0001_afni+orig’[0]’ -tshift 0 -prefix volreg 4Dvolume0001_afni+orig’[0…209]’

on Xterm and the terminal. I have used bash and tcsh and I get the same error. I am running the afni version “Precompiled binary macosx_10.7_Intel_64: Jan 20 2017 (Version AFNI_17.0.02)” on a macos Sierra 10.12.3. Could it be something with my macos version?

Not sure, but you could try another mac os package instead

@update.afni.binaries -package macosx_10.7_local

Try that. If it still doesn’t work, I could try on one of our systems here with your data.

I downloaded it but it can’t be installed

++ extracting package macosx_10.7_local.tgz…
tar: Error opening archive: Failed to open ‘macosx_10.7_local.tgz’
** failed to extract package macosx_10.7_local.tg

Along the lines of where Daniel was headed, you might be
having problems due to needing DYLD_FALLBACK_LIBRARY_PATH

The trouble you are having download is strange, too.

Would you please mail me the full output from afni_system_check.py?

afni_system_check.py -check_all

Please send it to afni.bootcamp AT gmail.com .

  • rick

Thank you Rick and Daniel. There are a few errors, including one with starting “3dAlliniate” which might have the same source as my problem with “3dVolreg”. It seems that you are correct reg the need of DYLD_FALLBACK_LIBRARY_PATH. I already sent the output of the afni check to afni.bootcamp AT gmail.com hopefully I can receive some help soon. Best, Luis

Sorry, I am still used to typing the FALLBACK version of that.
But you should be sure that DYLD_LIBRARY_PATH is set to
/opt/X11/lib/flat_namespace .


  • rick