3dUndump: FATAL ERROR -master: can't open dataset

Hi there,

I’m having an issue running 3dUndump – when I attempt to run:

3dUndump -prefix RAntCingulate -master anat_MNI+tlrc -srad 5 -xyz RAntCingulate.txt

I get the output:

++ 3dUndump: AFNI version=AFNI_20.2.19 (Sep 27 2020) [64-bit]
** FATAL ERROR: -master: can’t open dataset
** Program compile date = Sep 27 2020

However, when I run, afni anat+tlrc there doesn’t seem to be any issues. I have created text files with xyz values for the areas but I think the error is the issue with the dataset. Please let me know if there are any additional steps I need to take.

Intriguing… Are you sure that you can view “anat+tlrc” in the GUI, or is the GUI just opening and not actually showing you that specific dset (a possibility)?

What is the output of running the following in the location where you are running 3dUndump:

ls -l anat_MNI+tlrc*


… and if the “ls -l …” shows something, what is the output of:

3dinfo anat_MNI+tlrc



I’m really new at all of this so I apologize for being so unaware but when I run
ls -l1 anat+MNI+tlrc*
it tells me that there is no match.

When I originally “opened” the file I was just looking at an atlas to identify areas within the GUI.

Am I following the correct process for creating a template mask and then applying it to tlrc.BRIK.gz files? If so, how do would I add an anat_MNI+tlrc dataset to make the masking possible?

No worries. This command (I didn’t have the ‘1’ there, but that should just mean that the outputs would be put into 1 column):

ls -l anat+MNI+tlrc*

… lists out any files it can find that start with “anat+MNI+tlrc” and have any other possible characters after it (like anat+MNI+tlrc by itself, anat+MNI+tlrc.HEAD, anat+MNI+tlrc.BRIK, anat+MNI+tlrc.Michael_Jordan, or anything that fits that pattern). Soo, by getting no match there, indeed, that file does not exist in that directory to be used-- hence your original woe with 3dUndump. You need to copy that file there, or provide the path to it in your command.

The GUI probably opened, fine, but the GUI by default reads in all files in the current directory, as well as those in special “reference” or “atlas” directories, provided in your ~/.afnirc file (where a lot of options for AFNI behavior can be set).

It is possible that you have that reference dataset somewhere else that AFNI can find it. What is the output of copy+pasting this into a terminal:

@FindAfniDsetPath anat+MNI+tlrc


ps: we have some Intro to Linux material that Rick wrote, here:
It would probably be worth checking that out.

@FindAfniDsetPath anat+MNI+tlrc

Running this didn’t actually output anything but I am working with a colleague right now to figure out my issue. It seems that I took a tutorial too literally and didn’t modify things dependent on our dataset/bases. I appreciate all your help and how quickly your replied! Thank you for the resource.



I will just note that the fact that this command:

@FindAfniDsetPath anat+MNI+tlrc

… returned nothing means that AFNI couldn’t find a file of this name in any of: your current directory, your binary source code directory (where your AFNI commands are installed), nor any specified atlas/global directories.

Please just ping back with any other questions as they arise.

Note also that we have a lot of useful tutorials, grouped by topic:
… including this one that most closely emulates one of our classical AFNI Bootcamp set of courses: