3dttest prefix niml.dset fail

Hello, all.

I have a problem in doing 3dttest++.
My command was :

3dttest++ -prefix P009_JL/SUMA/Ttest.std.Gender_Searchlight_range2stim_G_cond_l.niml.dset -setA datasets

I checked that all -setA dataset existed.
But when I run this command, terminal says :

** cannot open NIML stream for file ‘Ttest.std.Gender_Searchlight_range2stim_G_cond_l.niml.dset’
** write_niml_file failed for ‘Ttest.std.Gender_Searchlight_range2stim_G_cond_l.niml.dset’

If I change the file name from .niml.dset to .niml or .nii, it works well, but only for niml.dset.
How can I fix it?

Thank you for all your working.

That command works fine for me.

It is likely that the P009_JL/SUMA directory does not exist
from where you are sitting, or that it is not writable by you.
From that same directory, what does this show?

ls -al P009_JL/SUMA
  • rick

I solved the problem!

I did it in the different folder, so I moved it to be done in the folder where the Test.* file would exist, then it’s DONE!

Thank you for your kind reply.

  • Hyehyeon