3dTcorrelate Spearman p-values


I’m attempting to use 3dTcorrelate to obtain Spearman correlation values for the relationship between parents’ and children’s responses during a task condition. I first used 3dTcat to put each subject’s values into sample datasets (‘parent_sample_17dyads+tlrc’ and ‘youth_sample_17dyads+tlrc’). I then ran the following command:

3dTcorrelate -spearman -polort -1 -prefix parent_youth_spearman_corr_3dtcorr1d_17dyads parent_sample_17dyads+tlrc youth_sample_17dyads+tlrc

The results seem to make sense, but the only problem is the output does not provide p-values. It just says “[N/A]” below the slider. This doesn’t happen when I use the default Pearson method. I tried using the ‘-automask’ option, but for some reason that doesn’t seem to work on my data. It actually tends to mask out the brain.

Is significance testing not supported for Spearman values with 3dTcorrelate?

Thank you,

Kara, you may try encoding some information into the header with something like

3drefit -substatpar # fico N-3 yourFile

where # is the sub-brick number for the correlation and N is the number of datasets in the input.

Hi Gang,

Thanks for your help. I tried the following command:

3drefit -substatpar 0 fico 14 parent_youth_spearman_corr_3dtcorr1d_17dyads+tlrc

But it does not seem to work. The command runs, but when I open the file everything is significant at a p-value of .005 (and I mean everything…). I also tried it with ‘31’ instead of ‘14’ because I wasn’t sure if I was supposed to enter the number of pairs for the correlation or the number of individual datasets. This doesn’t seem to help either. Is there something I am doing incorrectly? When I run the 3drefit command I get the message “changed statcode[0] to 2” but otherwise it runs just fine.

Thank you,