3dSkullStrip error: error while loading shared librarie


I am running 3dSkullStrip within an afniproc.py generated script and for only SOME subjects, I get this error:

3dSkullStrip -orig_vol -input ./__tt_mprage+orig -prefix ./__tt_mprage_ns
3dSkullStrip: error while loading shared libraries: libgsl.so.0: cannot open shared object file: No such file or directory
** ERROR: Could not strip skull

I have been searching similar topics on this message board, and I see comments to install libgsl. I tried a few different installation commands, and they don’t work. I tried:

sudo apt-get install gsl-bin

sudo rm /var/lib/dpkg/lock
sudo dpkg --configure -a
sudo apt-get update

And have not had any luck.

I am using MacBook OS. 10.12.4

Thank you!

Hi Daisy,

To make it easier, I suggest downloading the current 10.7_local
package. Then you should not need to worry about libraries much:

@update.afni.binaries -package macosx_10.7_local
  • rick

Thanks for you reply!

This is the feedback I get when I do that. (I very well may have done something wrong—I am new to AFNI).

– have AFNI binaries under /afs/dbic.dartmouth.edu/usr/pkg/afni/bin
– install dir: using existing /afs/dbic.dartmouth.edu/usr/pkg/afni/bin
– attempting to install package macosx_10.7_local under
install dir: /afs/dbic.dartmouth.edu/usr/pkg/afni/bin…
– have install dir
++ working in new temp dir, .tmp.install
mkdir: cannot create directory `.tmp.install’: Read-only file system
** failed to create new or remove old temp dir, .tmp.install


So that is a shared directory that you do not own?
Perhaps it means that other users have installed
the needed libraries via homebrew or something.

Do you know of anyone else there using that set
of binaries?

If you would like, we can try to resolve this via
email, since it may take a little back-and-forth

  • rick