3dQwarp killed


I am having an issue with 3dQwarp when running afni_proc.py (basically example 11 from the documentation without SSwarper). Below is a snippet of the output file that starts at line 2050. There were no errors prior to this section.

#Script is running (command trimmed):
  3dQwarp -prefix ./anat.un.aff.qw.nii -blur -3 -3 -workhard:0:1 -base ./base.nii -source ./anat.un.aff.nii 
/bin/sh: 3dQwarp: command not found
#**ERROR Failed in warping step
** ERROR - script failed
3dbucket: No match.

When I type 3dQwarp into command line, it says command not found and I noticed it is not in abin. I just updated AFNI binaries, and I have tried deleting abin and /.afni/help folders, restarting my computer, then reinstalling AFNI. 3dQwarp reappears, but then when I type it into command line, it says "zsh: killed" and the 3dQwarp file disappears from abin.

Below is the output of afni_system_check.py. AFNI and SUMA both load and all other functions appear to work; it is just 3dQwarp. I'd appreciate your help. Thanks in advance!

-------------------------------- general ---------------------------------
architecture:         64bit 
cpu type:             i386
system:               Darwin
release:              21.6.0
version:              Darwin Kernel Version 21.6.0: Sat Jun 18 17:07:25 PDT 2022; root:xnu-8020.140.41~1/RELEASE_X86_64
distribution:         10.16
number of CPUs:       8
apparent login shell: zsh
shell RC file:        .zshrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni           : /Users/monicaly/abin/afni
afni version         : Precompiled binary macos_10.12_local: Jul 28 2023 
                     : AFNI_23.2.02 'Marcus Didius Severus Julianus'
AFNI_version.txt     : AFNI_23.2.02, macos_10.12_local, Jul 28 2023, official
which python         : /Users/monicaly/opt/anaconda3/bin/python
python version       : 3.9.12
which R              : /usr/local/bin/R
R version            : R version 3.6.3 (2020-02-29) -- "Holding the Windsock"

instances of various programs found in PATH:
    afni    : 1   (/Users/monicaly/abin/afni)
    R       : 1   (/Library/Frameworks/R.framework/Versions/3.6/Resources/bin/R)
    python  : 1   (/Users/monicaly/opt/anaconda3/bin/python3.9)
    python2 : 0 
    python3 : 2 

** have python3 but not python2

testing ability to start various programs...
    afni                 : success
    suma                 : success
    3dSkullStrip         : success
    3dAllineate          : success
    3dRSFC               : success
    SurfMesh             : success
    3dClustSim           : success
    uber_subject.py      : success
    3dMVM                : success

------------------------ dependent program tests -------------------------
checking for dependent programs...

which tcsh           : /bin/tcsh
which Xvfb           : /opt/X11/bin/Xvfb

checking for R packages...
    rPkgsInstall -pkgs ALL -check : success

R RHOME : /Library/Frameworks/R.framework/Resources

------------------------------ python libs -------------------------------

++ module loaded: matplotlib.pyplot
   module file : /Users/monicaly/opt/anaconda3/lib/python3.9/site-packages/matplotlib/pyplot.py
   matplotlib version : 3.5.2

-------------------------------- env vars --------------------------------
PATH = /Users/monicaly/opt/anaconda3/bin:/Users/monicaly/opt/anaconda3/condabin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Library/Apple/usr/bin:/Users/monicaly/abin

PYTHONPATH (sub-shell) = 
R_LIBS (sub-shell) = 
LD_LIBRARY_PATH (sub-shell) = 
DYLD_LIBRARY_PATH (sub-shell) = :/opt/X11/lib/flat_namespace

----------------------------- eval dot files -----------------------------

----------- AFNI $HOME files -----------

    .afnirc                   : found
    .sumarc                   : found
    .afni/help/all_progs.COMP : found

--------- shell startup files ----------

   ** warning: .tcshrc does NOT seem to contain 'source .cshrc'
   -- (csh and tcsh will use different files)
   -- considered operations: path, flatdir, apsearch
   -- note: followers should not need edits, so edit flags should be 0
      (have 0 follower(s), which can be ignored)
   dot file test : want 1 modifications across 3 files:
      file             path  flatdir  apsearch        follower
      ---------------  ----  -------  --------        --------
      .cshrc           0     0        0               0     
      .tcshrc          0     0        1               0     
      .zshrc           0     0        0               0     
------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas    : found TT_N27+tlrc  under /Users/monicaly/abin

------------------------------ OS specific -------------------------------
XQuartz version      : 2.8.1

which brew           : /usr/local/bin/brew
brew version         : Homebrew 2.4.8

-- consider installing gcc under homebrew
-- consider installing glib under homebrew
++ found 1 dylib files under '/opt/X11/lib/flat_namespace'
   -- found 'libXt' dylib files:
-- recent OS X, cheating to check DYLD_LIBRARY_PATH in cur shell 'zsh'...
++ found evar DYLD_LIBRARY_PATH = :/opt/X11/lib/flat_namespace
-- recent OS X, cheating to check DYLD_LIBRARY_PATH in shell 'tcsh'...
++ found evar DYLD_LIBRARY_PATH = /opt/X11/lib/flat_namespace

=========================  summary, please fix:  =========================
*  just be aware: login shell 'zsh', but our code examples use 'tcsh'
*  dot file test : want 1 modifications across 3 files:
*  insufficient data for AFNI bootcamp
   (see "Prepare for Bootcamp" on install pages)

AFNI version info (afni -ver): Precompiled binary macos_10.12_local: Jul 28 2023 (Version AFNI_23.2.02 'Marcus Didius Severus Julianus')


Um, I don't know, for starters. Perhaps could you send your ~/.*rc files, and I'll see if anything there might be related?

If you run:

afni_system_check.py -dot_file_pack DOTFILES

... and then I will message you my email for sending the created DOTFILES.tgz.


Thanks, I didn't see anything odd in the dot-files.

The one minor update to recommend is what is pointed out by this line in the "Please fix" section:

*  dot file test : want 1 modifications across 3 files:

which refers to this line in the "shell startup files" section:

   ** warning: .tcshrc does NOT seem to contain 'source .cshrc'

... and to address that, you could copy+paste the following into a terminal, so that the ~/.tcshrc file, which has priority, also sources the similar/related ~/.cshrc file:

echo "" >> ~/.tcshrc
echo "source ~/.cshrc" >> ~/.tcshrc
echo "" >> ~/.tcshrc

Re. the odd behavior with 3dQwarp itself, I'm not sure. In the message title, you refer to 3dQwarp being "killed"---that is a technical term applied to processes that are using so much memory, the OS stops them from using up all RAM. But normally the message just appears as something like 3dQwarp killed, and things just stop, and there is certainly no removal of the program.

Searching online shows this kind of thing happens a bit with odd Homebrew installs or running Intel-architecture programs on Apple-Silicon (M1/M2) computers; but here, you appear to have an Intel architecture and appropriate binaries for that.

I will have to ponder a bit more and perhaps try to ask around.


I'll add that anti-virus software does sometimes quarantine certain programs on a whim, and perhaps 3dQwarp being moved into quarantine is what's going on here if it happens repeatedly. Can you check your antivirus logs (under Console in MacOS) or under the actual anti-virus program to see if it says anything.

If you download the binaries and then just run 3dQwarp directly with no options, does it still disappear?

Thank you both for your suggestions! Even after updating my OS, fixing the dot file as suggested, and another try at deleting and re-downloading the binaries, 3dQwarp still disappears. Yes, I have tried to run 3dQwarp with no options immediately after re-downloading, and it either says "zsh: killed" or "command not found"

I'm looking into removing some of the enterprise anti-virus software (Crowdstrike Falcon) that I no longer need as I'm no longer affiliated with the institution that required it on my personal Mac. Will keep you all updated if that's the issue!

Just to update everyone - the culprit was the anti-virus software removing 3dQwarp.

1 Like

Well, you certainly can't trust the author of that code. He's a very suspicious character. "An old desert rat", he once was called.

1 Like