3dNetCorr: number of voxels out of range is the same with different masks

Hi there,

I’ve run my 3dNetCorr command. Every time I run it I get a warning error 290 voxels skipped because they were constant in time (or some large value).
So after reading the documentation I realized this is probably because I’m not masking my ROI’s correctly. So after I ran melodic… from the output I got “mean.nii.gz” I did brain extraction tool (BET) to get a tight mask (0.8 threshold) for my mean brain thinking it may solve my issue. This mask was then added as an argument for “mask” for both 3dMatch and 3dROIMaker commands. However, I realized that I’m getting the exact same number of voxels being skipped in my warning error. I thought at least the number of voxels that would be skipped would decrease, but that wasn’t the case. I tried troubleshooting and going back to all the steps and everything seems right. The warning error doesn’t seem to change with the tightening of the mask.

I also wanted to note that my filtered_func data has a pix4=2 whereas all my other data has pix4=1 (I’m not sure if that’s valuable information that has a part to play in my output).

Thanks for your time.

Hi, Sondos-

I am afraid that I don’t know what “the filtered_func data has a pix4=2” refers to; I assume that is something specific to another software.

For the main issue with the ROIs and time series: Where are your ROIs coming from? If you overlay your ROIs on the “mask” data set, then do ROIs still stick out over it? And could you please copy+paste the 3dROIMaker command that you are using?