3dMVM error: undefined columns selected

Hi everyone, I’m trying to run a 3dMVM with two quantitative vars and an outcome measure with two levels (set up in first attachment). When running the script, I’ve been getting an error message:

Error in ‘[.data.frame’(lop$dataStr, , jj) : undefined columns selected
Calls: process.MVM.opts → [ → [.data.frame
Execution halted

Having trouble figuring out what exactly this is referring to. My first thought is that it must be a syntax/formatting error or a typo, but I can’t put my finger on where it is (apologies if that does turn out to be the issue). Is there something else that this set up is missing?

Jimmy, try changing

-qvars ‘NMfull*TotalUse’


-qvars ‘NMfull,TotalUse’

Also, are you sure you want to capture the interaction between NMfull and TotalUse through the specification -bsvars ‘NMfull*TotalUse’ instead of -bsvars ‘NMfull+TotalUse’? Lastly, be careful about the centering issue: https://afni.nimh.nih.gov/pub/dist/doc/htmldoc/statistics/center.html

Hi Gang,

Thank you very much for the feedback! I made the changes you suggested and the script and it has gotten farther along, although it is still not running as expected. I’m now receiving an error message about the syntax in glt 10 (that I’m sure applies to glts 11 and 12 as well), which must be centered specifically on the way I’ve got NMfull and TotalUse arranged. I’ve tried adding a colon and a space after NMfull in each case, but that does not seem to be the problem. Do you have any insight into what the issue might be there?

Thanks again,

Screen Shot 2021-07-27 at 9.58.46 AM.png


The post hoc inferences #10-12 do not make sense when you provide both quantitative variables in the specification. Could you clarify what you mean by those 3 lines?