3dMVM error in FUN()


I am trying to run 3dMVM with a voxelwise covariate. I get the error:

[1] "Start to compute 97 slices along Z axis. You can monitor the progress"
[1] "and estimate the total run time as shown below."
[1] "05/29/24 11:42:30.614"
Error in FUN(newX[, i], ...) : object 'residout' not found
Calls: aperm -> apply -> FUN
Execution halted

The syntax I am using within a bash script is (dollar signs replaced for pound signs to avoid formatting):

3dMVM \
-bsVars 'Drug*Group+Age+Sex+Basecov' \
-qVars 'Age' \
-vVars 'Basecov' \
-SS_type 3 \
-mask £{ROI_dir} /£{ROI}_resampled-to-subject-dimensions+tlrc \
-resid residuals \
-prefix followup_ANCOVA_£{ROI} \
-dataTable @£{dir}/dataTable.txt

I have updated my binaries with @update.afni.binaries -do_extras, but no luck. If I run the function without the covariate, everything works fine.

Thank you in advance for your help!


Welcome on board, Paulina!

What is the output for the following commands at the terminal?

afni -ver
R --version
R -s -e 'packageVersion("afex")'
R -s -e 'packageVersion("phia")'

Also, try running your 3dMVM without the line -resid residuals \ and see if it works.

Gang Chen

Dear Gang,

Thank you so much for your super quick reply!

I removed the -resid residuals \ line from the code and the function worked. Why is that?

Additionally - it looks like the function didn't output residuals, so I am not sure how to compute the smoothness of the output?

For completeness, the terminal output to the commands you suggested to run was:

afni -ver
Precompiled binary linux_ubuntu_16_64: May 27 2024 (Version AFNI_24.1.15 'Publius Septimius Geta')

R --version
R version 4.4.0 (2024-04-24) -- "Puppy Cup"
Copyright (C) 2024 The R Foundation for Statistical Computing
Platform: x86_64-pc-linux-gnu

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under the terms of the
GNU General Public License versions 2 or 3.
For more information about these matters see
Licenses - GNU Project - Free Software Foundation.

R -s -e 'packageVersion("afex")'
[1] 1.2.1

R -s -e 'packageVersion("phia")'
[1] 0.2.1

Thank you again!