3dDeconvolve thinks input Nifti is 5D

AFNI version info (afni -ver):
Precompiled binary 1: Jun 8 2023 (Version AFNI_99.99.99 'Alexios V Doukas the Bushy-eyebrowed')
(version is actually 23.1.07 being run on a Linux HPC (RedHat Enterprise Linux 9) via a module system)

Hi there,

I am attempting to run 3dDeconvolve, but keep getting errors to with my input image, saying that:

"AFNI can't deal with 5 dimensional NIfTI(/path/to/concatenated.nii.gz)"

and subsequently:

"FATAL ERROR: Can't open dataset '/path/to/concatenated.nii.gz'"

However, the input I am providing is 4D, and was actually created with 3dTcat (the nifti header of concatenated.nii.gz corroborates this - these are the values of dim: 4 220 220 26 2880 1 1 1).

The same error occurs when I instead input each of the individual blocks that make up concatenated.nii.gz and use -noblock.

The concatenated file is too big to upload, so here's a link to one of the individual block files, in case that helps!

The code:

3dDeconvolve -overwrite -jobs 6 -polort A \
    -input concatenated.nii.gz \
    -num_stimts 2 \
    -TR_times 1 \
    -stim_times 1 ${stim1_onsets} 'UBLOCK(1.5, 1)' -stim_label 1 stim1 \
    -stim_times 2 ${stim2_onsets} 'UBLOCK(4,1)' -stim_label 1 stim2 \
    -tout \
    -x1D MODEL_wm \
    -bucket stats.nii.gz

Thanks in advance for any advice!

We run into this once in a while, but it is always on somewhat peculiar system that makes reproduction difficult, and it would be great if we could figure out where this is coming from. And thanks for the dataset. Naturally I see no such issue here, unfortunately.

Your afni -ver output does not seem to show the build system information. Is there more information in the output than what is shown?

If possible, would you please try running that 3dDeconvolve command after modifying the dataset? Please run:

nifti_tool -rm_ext ALL -infile concatenated.nii.gz -prefix concat.noext.nii.gz

and then run the 3dDeconvolve command with the concat.noext.nii.gz dataset?


  • rick

Thanks Rick, I ran that code but unfortunately got the same error.

The afni -ver output in my original post is the full output. (The reason I know it is v23.1.07 (despite this output) is that I load AFNI through the HPC's module system as 'module load AFNI/23.1.07'.)

I could get in touch with the system administrators if there is a piece of information to do with the way it's been compiled which would be useful help with this issue?

To be comprehensive, I also module load GCC v11.3.0 and OpenMPI v4.1.4 alongside AFNI.

Thanks again,

From seeing "Alexios V Doukas the Bushy-eyebrowed", I think that means you are using a singularity instance built by NeuroDocker.

And actually, another thread that mentioned a similar "AFNI can't deal with 5 dimensional NIfTI" error had that kind of singularity, too:



Okay, we can produce this error locally, at least somewhat, based on a 'cmake' compilation. Now we have at least something partial to work with...

Thanks again for the dataset.

  • rick

Sounds good. Let me know if I can provide any more information from my end/if there are any more updates.

  • Josh