3dDeconvolve -stim_file uses one zero or HDF

Hi afni group,

I am using 3dDeconvolve to do subject level GLM, and I have the stim file as 0000011111000000000111, and also I have one from the afni function waver,

waver -TR 2 -numout 888 -peak 1.0 -input "$task"1D.mx > "$task"1D.1d

I wonder which one should I use when I define the parameter of -stim_file in 3dDeconvolve?

It’s a block design with varying durations, so I prefer using -stim_file rather than -stim_times.

Thanks a lot!


Hi Meng,

It might be better to get in the habit of creating actual timing files (with onset times). For 3dDeconvolve (and afni_proc.py), they will not work directly with the binary event files. Using waver (and 3dD -stim_file) is okay, but also somewhat antiquated.

Consider using make_stim_times.py to convert the binary event files to timing, instead.

  • rick

Hi Rick,

Thank you for your recommend.
I tried make_stim_times.py as you suggested, then where was another problem.
As my runs have different TRs, I tried with the option -run_trs which allows me to define TR number for each run, as example 2b did in the command page.

But it gave me an error: missing option -nt

My command is

make_stim_times.py -files SW1D.mx -prefix stim_times_SW -tr 2 -amplitudes -run_trs 179 169 172 187 181

I’m not sure where went wrong, since the run_trs option was gaven, -nt and -trs were not needed.

Thank you!


Hi Meng,

I ran that exact command without any error. Can you verify it?

What is the output of “afni -ver”?

Also, what does that input file look like? Would you mail it to me?

  • rick

Hi Rick,

Your suspicion is right, I updated to the latest version (previous version is AFNI_2011_12_21_1014), and the error was gone, everthing went well.
Thank you so much!


That is good to hear.

Sure, that AFNI_2011_12_21_1014 version label is at least 3 years old.
I am glad you are updating. :slight_smile:

  • rick