X11Error: Can't open display: 0.0


I am having a problem opening AFNI after I ssh into a drive at a different location from where I am. I am using a Windows 10 machine so I have to open AFNI using ubuntu and Xlaunch.

Using Ubuntu, AFNI opens up without any problems on my own computer. I get the following error when I try and open AFNI after I ssh into the other drive:

Initializing: X11Error: Can’t open display: 0.0
++AFNI is detached from terminal.

I tried a few things that were on this message board, but everything I have tried has failed.

Thank you very much for you help,
Maverick Smith

Hi, Maverick-

Most times I see that on Windows Subsystem Linux, it involves this part of the setup instructions:
I will assume that you have the vcXsvr installed.

First thing I would do, is close Ubuntu, start the vcXsvr, and then open an Ubuntu terminal and try (this would solve things if you have followed the setup instructions in that step, but not re-sourced your terminal’s ~/.*rc for the changes to be recognized by the terminal).

If that doesn’t work, then my guess is that the copy+pasting in step #4 there was not done; so, I would do that, and then open a new Ubuntu terminal.